Can't use '-chrome' to load chrome://navigator/content/foo.xul

VERIFIED INVALID

Status

()

Core
XUL
P3
normal
VERIFIED INVALID
18 years ago
10 years ago

People

(Reporter: John Morrison, Assigned: David Hyatt)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Overview Description:

  Can't use '-chrome' to go to chrome://navigator/content/foo.xul
  (i.e., can't use it to load an arbitrary, "non-standard" 
         chrome: URL).


Steps to Reproduce:

1) make a copy of xpfe/browser/resources/content/navigator.xul 
               as xpfe/browser/resources/content/foo.xul 

2) start mozilla ...

Actual Results: 

I get two assertions as mozilla starts up

###!!! ASSERTION: NS_ENSURE_TRUE(docShellElement) failed: 'docShellElement',
file nsXULWindow.cpp, line 843
###!!! Break: at file nsXULWindow.cpp, line 843
###!!! ASSERTION: NS_ENSURE_TRUE(docShellElement) failed: 'docShellElement',
file nsXULWindow.cpp, line 772
###!!! Break: at file nsXULWindow.cpp, line 772

and then the app hangs. (When I interrupt the hang, I have four threads
all in __poll or __sigsuspend, none of which have much XUL or layout
functions on the stack).

Expected Results: should be able to launch arbitrary chrome windows from 
 the -chrome command line arg.

Reproducibility: always

Build Date & Platform Bug Found:
  linux debug build, pulled at ~5pm May 16

Additional Builds and Platforms Tested On: none

Additional Information: 

  launching with 
  '-chrome chrome://navigator/content/navigator.xul' does work
  (same content, just a different name)

  also, creating a minimal bit of XUL as the contents of 'foo.xul'
  does not work either (hangs the same way).

(Apologies for spam: not sure whom this should go to, and apologies
if this is just due to temporary measure while chrome is rearranged).
(Assignee)

Comment 1

18 years ago
you are placing the file in dist/bin/chrome/packages/core/navigator/content, 
right? 
(Reporter)

Comment 2

18 years ago
Aargh. I feel stoopid. Emacs was kindly following the link from dist/bin...
over to browser/resources... (because it was a CVS file), so saving it out 
was not saving it in the dist/bin location. Smart emacs, dumb John. 
Invalid.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

18 years ago
verified stupid.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.