If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Attachments icons should switch to the smaller icons when the number of attachments with the big icons would cause the attachments pane to overflow

RESOLVED DUPLICATE of bug 382821

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 382821
10 years ago
7 years ago

People

(Reporter: Peter Lairo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007090905 Minefield/3.0a8pre
Build Identifier: version 3.0a1pre (2007090904)

Attachments icons should switch to the smaller icons (on left of filenames) when the number of attachments with the big icons would cause the attachments pane to overflow.

Reproducible: Always

Steps to Reproduce:
1. receive e-mail with ~10 attachments
Actual Results:  
Large attachments' icons cause premature overflow of the attachment pane with too few attachments visible at one time.

Expected Results:  
Attachments' icons should auto-switch to the smaller icons (to the left of the filenames) when the large icons and the number of attachments would cause the attachment pane to overflow.

This would allow for the larger icons in the vast majority of cases (~1-3 attachments) but would allow the user to see more filenames when there are many attachments. 

Justification:
Seeing as many attachments as possible is more important than having large attachment-icons IMO!
(Reporter)

Comment 1

10 years ago
BTW: I don't like the large icons method because it forces the filenames to be needlessly truncated - a bad thing with ever longer filenames. 

The small icon method could allow the filenames to be as wide as the message-panel and/or half the width if the number of attachments would justify displaying the list of attachments in two columns.
Version: unspecified → Trunk

Comment 2

10 years ago
See also bug 382821 comment 1.

Comment 3

10 years ago
I would prefer bug 382821 comment 4,
to be able to choose *no* icons.
Sound like a dupe of bug #395695.
Whiteboard: DUPEME
(Reporter)

Comment 5

8 years ago
This is bug 395695! :-\
(In reply to comment #5)
> This is bug 395695! :-\

I'm sorry Peter... :-(

Sound like a dupe of bug #382821
(In reply to comment #6)
> (In reply to comment #5)
> > This is bug 395695! :-\
> 
> I'm sorry Peter... :-(
> 
> Sound like a dupe of bug #382821

Agreeing this would be solved by smal icons.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382821
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.