Firefox reports a copy already running when it is not due to empty Profile folder

RESOLVED DUPLICATE of bug 278860

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 278860
12 years ago
11 years ago

People

(Reporter: PJ_1004, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

For some reason I get this problem constantly.   Firefox will attempt to open but then reports the following error message: "A copy of Firefox is already open.  Only one copy of Firefox can be open at a time."

I have tracked it down to the Profile directory.  If the "Profiles" directory exists inside the "~/Library/Application\ Support/Firefox" folder but contains no profile - then this error occurs.  If I delete the "~/Library/Application\ Support/Firefox" directory itself, the application then launches and creates a default profile correctly.

I can also replicate the issue by editing the profiles.ini file to point to a differently named Profile which does not exist.  If I then rename the profile to match (i.e. firefox.default) it works fine.

Cheers,
PJR
--

Reproducible: Always

Steps to Reproduce:
1. Delete the "~/Library/Application\ Support/Firefox/Profiles/firefox.default" profile
2. Attempt to Launch Firefox
3. See the error message complaining that a copy of Firefox is already open.
Actual Results:  
I saw the error:

"A copy of Firefox is already open.  Only one copy of Firefox can be open at a time."

Expected Results:  
Opened the application and if no profile exists - either create a blank profile in the same location as specified within the profiles.ini file, or prompt me to create a new profile or perhaps select the profile I wish to use.?

I am able to replicate this issue under a local administrator user on a mac machine as well by deleting the abcxyz.profile directory.  To fix I need to delete both the empty "Profiles" directory as well as the "profiles.ini" file.

I do not know what is causing some profiles on this site to delete themselves, however I would assume that if the software is looking for a profile that does not exist - I would get a different error message to "A copy is already open" but rather expect to see some form of prompt to create a new profile or select an existing profile using the profile manager or similar.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278860
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.