Importing from Eudora: When Eudora AB can't be found, manual selection method fails

RESOLVED WONTFIX

Status

Thunderbird
Migration
RESOLVED WONTFIX
10 years ago
a year ago

People

(Reporter: Geoffrey C. Wenger, Assigned: Geoffrey C. Wenger)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patchlove])

Attachments

(2 attachments)

(Assignee)

Description

10 years ago
Eudora data (including the Address Book) is found using the registry. When that method fails (because the Eudora data was moved from another machine or because the data was moved to a different location on the machine and Eudora was not run to update the location stored in the registry) a dialog is presented which allows the user to select the directory containing the Address Book data.

Unfortunately after the user selects the directory containing the address book, the import fails with a dialog that says: "Can't import empty address book NameOfDirectorySelected" (where NameOfDirectorySelected is the name of the directory selected).

Some discussion of this bug was in bug #28006, but the likely original cause of that bug is fixed and the discussion combined two different bugs into one.
related
 bug 274021 
 bug 82481 
perhaps you will want dupe them, or mark this bug as as blocking them
(Assignee)

Comment 2

10 years ago
Created attachment 280511 [details]
Allows user to set registry without running Eudora.

Best current workaround is to run Eudora (e.g. 7.x) with the data that you want import.

Another workaround is to download this attachment "SetEudoraPathInRegistry.reg". After downloading it, right-click it and choose "Edit". Edit it as described in the file to point to your Eudora data. Save your changes. Then double-click it and choose "Yes" when you're asked something like "Are you sure you want to add the information in SetEudoraPathInRegistry.reg to the registry?". This workaround should work for Windows XP and earlier. I'm not sure about Vista.
(Assignee)

Updated

10 years ago
Attachment #280511 - Attachment mime type: application/octet-stream → application/test
(Assignee)

Updated

10 years ago
Attachment #280511 - Attachment mime type: application/test → text/text
(Assignee)

Comment 3

10 years ago
Modified because although I was initially approaching this bug from a Windows centric point of view, it actually affects all platforms.
Status: NEW → ASSIGNED
OS: Windows XP → All
(Assignee)

Updated

10 years ago
Duplicate of this bug: 368631
(Assignee)

Comment 5

10 years ago
Created attachment 305101 [details] [diff] [review]
Trunk patch that allows directory to be selected during import as address book location without subsequent code rejecting it.
(Assignee)

Updated

10 years ago
Attachment #305101 - Flags: superreview?(mscott)
Attachment #305101 - Flags: review?(bienvenu)
(Assignee)

Updated

10 years ago
Keywords: checkin-needed

Updated

10 years ago
Attachment #305101 - Flags: superreview?(mscott) → superreview+
Don't add checkin-needed until the patch has _ALL_ reviews required.
Keywords: checkin-needed

Updated

9 years ago
Attachment #305101 - Flags: review?(bienvenu) → review+

Comment 7

8 years ago
I downloaded the file, but it is greek to me.  Where and what field / location / line do I change to point to the location of my Eudora address book.  this may be obvious to a programmer which I am definitely not.  I do know how to edit the file and I do know how to run the reg file.  When I installed TB 2.0.0.23 (10 minutes ago)it found all my messages but still did not find my addressbook which is to big for me to just re-enter everything.
Duplicate of this bug: 433273

Comment 9

2 years ago
This bug has had an R+ for 7 years.

Can we move forward with a checkin or close as wont fix or something?
Someone would need to pursue it and assess whether it still applies, etc.

There are 4 other patches authored by Geoffrey http://mzl.la/1JC4tkQ
Status: ASSIGNED → NEW
Whiteboard: [patchlove]

Comment 11

a year ago
Importing from Eudora was removed from Thunderbird in bug 1243498.
Please see http://kb.mozillazine.org/Importing_from_Eudora_-_Thunderbird on how you can still import from Eudora if you need that.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.