places.dtd cleanup

RESOLVED FIXED in Firefox 3 beta1

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: u88484, Assigned: u88484)

Tracking

Trunk
Firefox 3 beta1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

17.73 KB, patch
(not reading, please use seth@sspitzer.org instead)
: review+
mconnor
: approval1.9+
Details | Diff | Splinter Review
(Assignee)

Description

11 years ago
Created attachment 280596 [details]
raw version. patch coming

I was looking through lxr today for something and came across the places.dtd files, man what an eyesore to read. So I took the liberty of cleaning it up to fix the spacing/line break/tabs or whatever else you want to call it. I thought the file would have been small since less lines but for some reason the file ended up bigger...weird?  Anyways I posted the text file here incase someone wants to create a patch before I get home this evening.
(Assignee)

Comment 1

11 years ago
Created attachment 280888 [details] [diff] [review]
patch
Assignee: nobody → supernova_00
Status: NEW → ASSIGNED
Attachment #280888 - Flags: review?
(Assignee)

Updated

11 years ago
Attachment #280888 - Attachment is patch: true
Attachment #280888 - Attachment mime type: application/x-unkown → text/plain
(Assignee)

Updated

11 years ago
Attachment #280888 - Flags: review? → review?(sspitzer)
Comment on attachment 280888 [details] [diff] [review]
patch

I think dietrich just made changes to this file (for bug #387740), so I think this patch has bit-rotted.
Attachment #280888 - Flags: review?(sspitzer)
(Assignee)

Comment 3

11 years ago
Created attachment 281383 [details] [diff] [review]
unbitrotted

Unbitrotted
Attachment #280596 - Attachment is obsolete: true
Attachment #280888 - Attachment is obsolete: true
Attachment #281383 - Flags: review?(sspitzer)
Comment on attachment 281383 [details] [diff] [review]
unbitrotted

r=sspitzer
Attachment #281383 - Flags: review?(sspitzer) → review+
Comment on attachment 281383 [details] [diff] [review]
unbitrotted

thanks Kurt.

drivers: this makes life easier for localizers, as well as improving readability, which will help prevent bugs like bug 396689.
Attachment #281383 - Flags: approval1.9?

Updated

11 years ago
Attachment #281383 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Checking in browser/locales/en-US/chrome/browser/places/places.dtd;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/places/places.dtd,v  <--  places.dtd
new revision: 1.31; previous revision: 1.30
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M9

Comment 7

11 years ago
http://lxr.mozilla.org/mozilla/search?string=view.columns.label
view.columns.label  is now defined twice. Not good, indeed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #7)
> Not good, indeed.

And not this bug, indeed. Not caused by it, as you could see by counting the number of them in the "-" lines, and not something this bug is responsible for fixing, as you could see by reading comment 5.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED

Comment 9

11 years ago
ouch, sorry. CVS blame only shows the last version of this file, hence, I thought those strings came with it.

My bad.
*hides in the bushes*
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.