Downloading from link to non-writable default dir causes odd behaviour

RESOLVED DUPLICATE of bug 326228

Status

()

--
major
RESOLVED DUPLICATE of bug 326228
11 years ago
10 years ago

People

(Reporter: mozdev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6 Mnenhy/0.7.5.0
Build Identifier: (Debian package iceweasel(firefox) 2.0.0.3-1)

I have a restricted user on my system whose home directory is not writable by him (anymore). However, Firefox/Iceweasel still takes the home directory as the default location for downloads. Now when I click on some link which points to a download (binary content like a .zip or tar or some other file type not known to firefox), the usual popup asking for the location to save to pops up with the current directory set to ~restricted_user. When I confirm, no error message pops up nor does any download actually happen. After this, when I click on the download link again, nothing happens at all. Only when I right-click->Save_link_as, can I start a new download. But the left-click remains useless/responseless.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
1) Error message on first try that firefox can't save to the specified location
2) New save-file popup on subsequent clicks

Updated

11 years ago
Whiteboard: DUPEME

Comment 1

11 years ago
Resolving duplicate.
Please, mention in that bug any details not mentioned there yet.

Also, please check if the bug is still present in the latest trunk builds. You can get one from
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 326228
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.