Places keyword should be called nickname

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
12 years ago
9 years ago

People

(Reporter: naylor83, Unassigned)

Tracking

({uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007090504 Minefield/3.0a8pre

To avoid confusion with "Tags", the places (bookmark) "Keyword" field should be labelled "Nickname" instead. Nickname is also a better description of how the field is used.

Also, using the same label as in Opera can be considered an extra bonus.

Reproducible: Always

Steps to Reproduce:
1. Right-click any bookmark/places entry
2. Click "Properties"
Actual Results:  
There is a field labelled "Keyword".

Expected Results:  
There should be a field labelled "Nickname".
(Reporter)

Updated

12 years ago
Flags: blocking-firefox3?
Nickname is usually associated with user accounts, so i don't think this is a good idea...
(Reporter)

Comment 2

12 years ago
Maybe there is some other label that would be better?

Comment 3

12 years ago
I'm going to take the liberty of removing the blocking request to save the drivers time from reading an unconfirmed RFE bug.  They would not stop a release because of this.

You do kinda have a point with this though...
Flags: blocking-firefox3?
(Reporter)

Comment 4

12 years ago
Having thought a little more about it, I agree that nicknames is usually associated with friends or contacts, but I still think it is the best name for the current "Keyword".

Comment 5

12 years ago
How about "Shortcut"?
Keywords: uiwanted
I think you'll want to run this by beltzner / faaborg for ui-r before we change it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Changing the name will cause confusion for people transitioning from previous versions of Firefox.  Also, the keyword field is currently hidden behind a progressive disclosure control in the places organizer, and in properties.  You have to be looking pretty hard to find it, which means you also probably know the difference between tags and keywords.  Overall I think changing the name might do more harm than good.
(Reporter)

Comment 8

12 years ago
I think the people savvy enough to fill out and use the keyword field won't have any trouble understanding what happened if their Keyword field is called Nickname  in Firefox 3. Especially if they look at an existing bookmark where they already filled out the field.
If we introduce both tags and nickname how will they determine:

keyword == tags
keyword == nickname

One is plural, but when we start localizing into 40 languages the translations might start to cause confusion.

Comment 10

12 years ago
I was thinking about Keywords and Tags recently and was looking at Bug 89001 ("File Bookmark Dialog should take keyword, comment, etc") and Bug 249468 ("Add all bookmark keywords to location bar autocomplete drop-down list") - which got me wondering whether bookmark Keywords could be done away with altogether now that we have Tags. But after some consideration, I came to the conclusion "no" - I might, for example, have 6 MySpace pages tagged "myspace" including 1 which is my own page which I've also keyworded "myspace" for quick access. Tags alone won't do. 

All of us reading this know that "Keyword" = "a quick and efficient way of accessing a webpage; a URL alias" and in fact, for the last decade, AOL has promoted the use "AOL Keywords" on their website, print and tv/radio ads/announcer-spots-- "keyword" there having the same meaning as above. "Keyword" is what it is, it's not all that difficult to differentiate from "Tags". If a user doesn't know what it means or how to use them -- well then IT'S TIME FOR THEM TO LEARN! Ah.. well, perhaps that's the problem--go to Firefox's 'Help  Contents' and type in 'keyword' in the search box there... nothing comes up!!!

This is a particularly large oversight as we've always had search keywords and more recently the easy adding of them via the "Add a Keyword for this Search" context menu, and now in Minefield there's a new (long-overdue) "Keyword" field in 'Manage Search Engines'.

Perhaps if Keywords were made more visible - for example adding a place for them to be entered in the 'Add Bookmarks' dialog (instead of having to resort to Properties, Bookmarks/Places Organizer, or an extension), then there would be no need for this Bug & debate.

But hey if the name does have to change for whatever reason, I'll submit "URL shortcut" be used. No confusion.

Comment 11

11 years ago
I agree that the name "keyword" should change. I like either "nickname" or "shortcut". I do not think that "nickname" would be confusing because of its use in email; I think users of Firefox know that bookmarks are for web pages, not people. (I guess this would be more problematic in SeaMonkey.)

I disagree with Alex in comment 7 that users upgrading from previous versions of Firefox would be confused. In other system transitions I have been involved with, an old name from an earlier version is consciously discarded to prompt users to take a fresh look at related/new functionality. In this case, keywords were used by various users both as shortcuts and as tags in pre-3 Firefox. Now we have 2 separate entities, and "tags" clearly takes over the second usage. I think it best to change "keyword" since some of its functionality has been split off.

I also disagree that keywords are so difficult to find that only expert users will find and use them. Even if that were so, why would we want to make things difficult for more novice users to find and understand the "keyword" functionality?

Comment 12

11 years ago
See also bug 424836.
We might end up calling keywords whatever name we use for ubiquity commands if that gets added to Firefox (commands, verbs, actions, etc.) 
see comment #7, user-inertia is very strong, we're not going to rename this many-years-old and narrowly-used feature. the right way to resolve this is to use tags or some incarnation of ubiquity commands, for a richer solution in a future version (Keywords 2: Electric Boogaloo?).
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.