Unable to save your message as draft

RESOLVED INCOMPLETE

Status

Thunderbird
Message Compose Window
RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: F W Stone, Unassigned)

Tracking

({testcase-wanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-07-14)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: 2.0.0.6 (20070728)

While working on a message, in this case, adding names to the distribution list, the message "Unable to save your message as draft.  There was an eror attaching.  Please check if you have access to the file." pops up.

This message being worked on originated as Message --> Edit message as new

It was HTML format and some of the internal table cell were removed.  However, while adding names to the distribution list the error occurred.

Each time the error occurs, an entry is made in the temp file --
nsmail-4.tmp
nsmail-3.tmp
nsmail-2.tmp
nsmail-1.tmp
nsmail.tmp

The size for all files is 0 KB

They cannot be deleted --

Error Deleting File or Folder

Cannot delete nsmailxx: it is being used by another person or program.
Close any programs that might be using the file and try again.

All 5 versions of the file are being used.

The only time I have seen this error is when a message is being edited as a "NEW" message [ctrl+e].

typically if the body of the message is deleted, the distribution list can be saved.

Unfortunately Ctrl+a on the body does not copy any graphics in the message.  There are place holders for the graphics but the message must be edited or created again.

After the body of the message has been deleted, the "message" can be saved.  It consists of the distribution list and subject.  However, the "nsmail" cannot be deleted.  They cannot be deleted until Thunderbird is closed.

this is not the first time this has occurred.  However, this is the first time I have taken the time to see what was going on in the temp directory.

Reproducible: Sometimes

Steps to Reproduce:
1.Take a message Edit as new - that has content more than ascii text
2. Start adding people to the distribution list
3.  This is NOT guaranteed to be reproducible every time.
Actual Results:  
See initial discussion.

Expected Results:  
Do not expect the error.
(Reporter)

Comment 1

11 years ago
I have just gone back to redo the message.

I seem to be able to reproduce this at will.

NOTE:  The message is HTML, not plain text.

select the message
ctrl+e  to get the message open to edit.  SAVE the message as a draft.  This seems to always be successful, as long as other changes have not been made.

If the body is changed and an attempt to resave the message is made, then it fails. 

Starting again, depending on how the distribuiton list is edited --

The distribution list looks like --
Reply-To:  name@domain.com
      To:  Undisclosed-Recipient:;
     Bcc:  name@domain.com

The message with the above distribution list and no other changes can be saved as a draft.

If the distribution list is changed to --
Reply-To:  name@domain.com
      To:  
     Bcc:  name@domain.com

it cannot be saved.

If a new message is started with a distribution list with a missing entry, 2nd example, it CAN be saved.

If the distribution list is edited so that there are no blank entries and the body is not changed, then it seems that it can be saved  or sent.  When it cannot be saved, it cannot be sent either.

(Reporter)

Comment 2

11 years ago
For testing, the environment for version 3, it was run using Microsoft VirtualPC 2004 --

The same process for reproducing the problem was tried using  version 3 alpha 1 (20070204).  The problem could not be reproduced.

When thunderbird-3.0a1pre.en-US.win32.installer.exe was installed from 9/16/2007 and 9/15/2007, they both crashed and no tests could be performed.

Comment 3

11 years ago
The startup crash is bug 394190. Anyway, couldn't reproduce on linux/trunk.
(Reporter)

Comment 4

11 years ago
This is NOT a startup crash.

I have been able to reproduce this with a long message.  It appears ANY change to the distribution list will cause the message to become unusable.

Additional text from the message was removed, then saved.

One of the names of the distribution list was removed.  It could not be saved.

If anyone is interested, I will be happy to send a message that they can experiment with to reproduce the problem

Fred
(Reporter)

Comment 5

11 years ago
Additional information:

The message had some text removed as described above and saved.

Next " 1"  that is   space 1  was added to the subject, no quotation marks, and it then became impossible to save.  I was going to attempt different series of messages with different ending digits on the subject to help track progress.

Next procedure --

The original message was "ctrl-E" then saved, successfully.  The subject was modified with " 1" and it immediately could not be saved or sent.
(Reporter)

Comment 6

11 years ago
Thunderbird 2.0.0.6 was replaced with version 3.0a1pre (2007092905).  Version 3 has it's problems too.

I was able to eventually edit the original down to the point that most of the text had been deleted.  There was a point that to delete more caused one of the images in he message to not be visible.  There was a place held but no image.

Trying to use ctrl-E in version 3 seemed to cause an immediate crash.

To accomplish the edits, the image was saved.  A copy was made to another folder created to hold progressive copies of edits.  The "draft" was edited.  Should a failure of image or save occur, then the last good version in the special folder was copied back to the drafts folder.  The message was double clicked to open it for editing.  A few changes were made, saved, then copied to the special folder.

This process was repeated until enough of the text was removed.  I reached a point that I was not willing to spend more time trying to edit the message to delete a few (less than 10) characters at the end of the message.

When ver 3 crashed, it did send a report.  There were two or three of these crashes.

While on the subject of ver 3, I noticed that there was no notification on the account column that new messages were available.  Ver 2.0.0.6 had a small orange sunburst to indicate new messages.  This was helpful, especially when there are several accounts. I've got 23 accounts.

The SMTP outgoing mail server settings had to be changed from 2.0.0.6 so that ver 3 would send mail.  It was necessary to uncheck "Use name and password" for the smtp server.  However, I can't be sure that my ISP has not made some changes in the past few minutes.  A test using another smtp server seemed to work with the old settings.

this is included here for version 3 because I don't know where to provide feedback for ver 3.
(Reporter)

Comment 7

11 years ago
Disregard the comment about the sunburst NOT appearing.  It seems to be present.

Comment 8

11 years ago
Can you attach the test case message to this bug (use the " add an attachment" link above)? 

As for the crashes you mention, please give the crash ids.

Comment 9

10 years ago
F W need crashid & testcase :)
 http://kb.mozillazine.org/Talkback#Getting_an_incident_ID
Whiteboard: closeme 2008-06-25
(Reporter)

Comment 10

10 years ago
My problems have been with --

https://bugzilla.mozilla.org/show_bug.cgi?id=327285

I have not encountered any crashes.  However, with the referenced bug, I do have failures of Thunderbird that can be demonstrated.

I do not know if the two are related.

I am currently using version 2.0.0.14 (20080421) of Thunderbird and only have a problem with the referenced bug 327285.

I have taken a message that causes the problem.  Moved it to another account os that it is the only message in the folder - the TRASH folder.  When the message is "edit as new"  CTRL-E, and the distribution list is changed, I do encounter the problem.  This folder has been zipped.  The message that was zipped was deleted from the trash folder.  The file was then unzipped and copied back to the account as TRASH to verify that nothing had changed.  When the edit as new was attempted again, the same failure was repeated.

If you would like to have this zip file, let me know.

Thanks.
Whiteboard: closeme 2008-06-25

Comment 11

9 years ago
F W, you can sanitize the message addresses (i.e. save it as .eml file and edit the file) and attach it to the bug, or email me the zipped original.
Component: General → Message Compose Window
Keywords: testcase-wanted
QA Contact: general → message-compose
Whiteboard: closeme 2009-07-14
(In reply to comment #0)
> Each time the error occurs, an entry is made in the temp file --
> nsmail-4.tmp
> nsmail-3.tmp
> nsmail-2.tmp
> nsmail-1.tmp
> nsmail.tmp

This undeleted temp files is also observed by duplication test of your bug 327285 using your test mail you attached to bug 327285. (Edit As New/Sava As Draft is sufficient).

> They cannot be deleted --

These undeletd temp files looks to be kept open if "Save As Draft" failure occurs. Termination of Tb is probably required to delete such garbages.

> Steps to Reproduce:
> 1.Take a message Edit as new  
(In reply to comment #1)
> NOTE:  The message is HTML, not plain text.

DUP of your bug 327285, isn't it?
(In reply to comment #1)
> To:  Undisclosed-Recipient:;

FYI.

This header doesn't produce "Save As Draft" error. It's saved as-is.
If "Send Later", next error dialog is displayed if Tb 2.0.0.21/22, and it is never saved in "Unsent" folder.
> Send Message
>   ! Undisclosed-Recipient:; is not a valid e-mail address because it is not of the frm user@host. You
>     must correct it before sending the e-mail.
>                             [ OK ]
It's already known issue, "group address is not supported", and is probably fixed recenltlly by Tb trunk. (i.e. Group address itself doesn't have relation to problem of this bug , "unable to save as draft".)
Depends on: 327285
No longer depends on: 327285
Depends on: 327285
RESO INCO per lack of response to last question. If you feel this change was made in error, please respond to the bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.