[10.4] Some .dfonts (Helvetica, Courier) do not display italics.

RESOLVED DUPLICATE of bug 364713

Status

()

Core
Graphics
P4
major
RESOLVED DUPLICATE of bug 364713
11 years ago
6 years ago

People

(Reporter: philippe (part-time), Assigned: jtd)

Tracking

({regression, testcase})

Trunk
PowerPC
Mac OS X
regression, testcase
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

11 years ago
Created attachment 280694 [details]
testcase

The style is contained within the font, even if it is not listed in Fontbook, the Cocoa Font panel shows it (just open up TextEdit).

Safari (webKit builds) and Firefox 2.0 are correct.
Flags: blocking1.9?
(Reporter)

Comment 1

11 years ago
Created attachment 280696 [details]
screenshot

Helvetica in Textedit (with fontpanel)

Updated

11 years ago
Flags: blocking1.9? → blocking1.9+
(Assignee)

Comment 2

11 years ago
Created attachment 282656 [details]
testcase screenshot in ff 2.0.0.7
(Assignee)

Comment 3

11 years ago
Created attachment 282657 [details]
testcase screenshot in ff trunk
(Assignee)

Updated

11 years ago
Assignee: nobody → jdaggett

Updated

11 years ago
Priority: -- → P4
This WFM on 10.5.
Summary: Some .dfonts (Helvetica, Courier) do not display italics. → [10.4] Some .dfonts (Helvetica, Courier) do not display italics.

Comment 5

10 years ago
Can you try a recent build?
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> Can you try a recent build?
> 
No changes on 10.4.11/ppc (latest camino and minefield builds): still a failure.

(Assignee)

Comment 7

10 years ago
The Helvetica and Courier .dfont files on 10.4 only include Regular and Bold faces, there are no italic faces.  10.5 ships will a full set of faces, Regular, Bold, Italic and Bold Italic.  

So the reason for the lack of italics on 10.4 is the lack of support for "synthetic" bolding and obliqueing.  We got this for free in FF2 by using QD drawing API's but we need to do this ourselves in FF3.  See bug 364713.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 364713
That doesn't make sense, given that the Cocoa font panel shows Helvetica Oblique as a "font", which the panel doesn't do in the relevant CJK fonts from bug 364713.

Or are you saying that "font" in the panel is some sort of internal alias to code to render synthetic italics?
(Assignee)

Comment 9

10 years ago
Created attachment 296021 [details]
helvetica in font panel (from TextWrangler)

Hmm, I see what you're saying.  The font panel shows two oblique faces that don't show up in FontBook.  Very strange.  These are definitely not separate faces, the Helvetica.dfont file on 10.4 only contains two faces.  Might be some sort of AAT variation, maybe?  Will investigate.
(Assignee)

Comment 10

10 years ago
Created attachment 296023 [details]
helvetica in FontBook
(Assignee)

Comment 11

10 years ago
reopening until i can figure out how Apple apps magically display non-existent font faces!
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
John, anything new here?  Not putting this back on blocking list -- should it still be?

Updated

10 years ago
Flags: tracking1.9+ → blocking1.9-

Comment 13

10 years ago
Helvetica is not only popular, but also the default sans-serif font used by Firefox.  As a result, this bug affects http://planet.mozilla.org/, making posts such as sayrer's "Internal Structures" (which uses italics for quotes) confusing.

Comment 14

10 years ago
(Or should my whining apply to bug 364713?)
(Assignee)

Comment 15

10 years ago
(In reply to comment #14)
> (Or should my whining apply to bug 364713?)

Yup.

(Assignee)

Comment 16

10 years ago
As part of the work for bug 419370, the bogus italic faces that Cocoa claims
exist for Helvetica/Courier under 10.4 are trimmed out of the font list:

http://mxr.mozilla.org/mozilla/source/gfx/thebes/src/gfxQuartzFontCache.mm#790

Will deal with general synthetic rendering of italic for Helvetica/Courier as
part of the work for 364713.  Will reopen if we discover something absolutely
goofy about these fonts that warrants special care.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 364713
(Assignee)

Comment 17

10 years ago
Confirmed fixed by 364713 with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008032004 Minefield/3.0b5pre
You need to log in before you can comment on or make changes to this bug.