Closed Bug 396163 Opened 12 years ago Closed 12 years ago

JS error: "Can't add a login with a null or empty username" when trying to login with an empty with empty user name

Categories

(Toolkit :: Password Manager, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 386150

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

Attached file testcase
See testcase, I get this error in the error console, when trying to login with an empty user name and then clicking on the "Remember" button on the infobar of the password manager.

Error: [Exception... "'Can't add a login with a null or empty username.' when calling method: [nsILoginManager::addLogin]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/mw/Bureaublad/moz/firefox20070912/components/nsLoginManagerPrompter.js :: anonymous :: line 344"  data: no]
Source File: file:///C:/Documents%20and%20Settings/mw/Bureaublad/moz/firefox20070912/components/nsLoginManagerPrompter.js
Line: 344
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386150
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.