mail.default_cc does not work (doesn't cc the address specified by default on new emails)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: cgz2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: version 2.0.0.6 (20070728)

I'm trying to do #5 on the URL listed above to default cc my boss on emails.  It doesn't appear to have any effect... I'm simply putting his email address for the value.

Reproducible: Always

Steps to Reproduce:
1.Open config editor
2.Edit mail.default_cc to contain an email address
3.Create a new email... no default CC is in the email.
Actual Results:  
Nothing happens

Expected Results:  
Expect new emails to have CC:person@address.com (set in config editor) by default
Funny that someone would take the time to write up something which very obviously doesn't work, and hasn't worked that way since Communicator 4.75 - despite there having been some migration code that copied the misnamed mail.default_cc (which was actually default_bcc) around, CVS archaeology says it wasn't ever used by any Mozilla product, just eventually replaced by the current working identity-based system.

Steps to do what you want:
1. Tools - Account Settings...
2. Click the name of the account in the left pane, then the Manage Identities... button on the right
3. Select an identity (probably the only one), click Edit...
4. On the Copies & Folders tab, check the box to "Bcc these email addresses:" and enter his email address and click OK

If you really like doing things the hard way, instead of the roundabout UI way, that would give you prefs like mail.identity.id1.doBcc (a boolean, true) and mail.identity.id1.doBccList (a string, goats@foopy.com), but with more than one account, and thus more than one identity, keeping the numbers straight is a pain, and the UI is simpler.

(And I already have a patch to remove that unused default pref, along with a couple dozen others, or I would turn this bug into a "don't fool another person into thinking that's how it's done" remove-it bug.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.