window.focus doesn't un-minimize windows

RESOLVED FIXED in Camino1.6

Status

Camino Graveyard
General
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Bec, Assigned: Stuart Morgan)

Tracking

({fixed1.8.1.8})

unspecified
Camino1.6
PowerPC
Mac OS X
fixed1.8.1.8
Bug Flags:
camino1.5.2 +

Details

(Whiteboard: [camino-1.5.2], URL)

Attachments

(3 attachments)

2.50 KB, application/zip
Details
781 bytes, text/html
Details
fix
1.24 KB, patch
Josh Aas
: review+
Mike Pinkerton (not reading bugmail)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/419.3 (KHTML, like Gecko) Safari/419.3
Build Identifier: Version 2007080914 (1.5.1) http://www.mozilla.org/projects/camino/

Using the javascript code: if(window.focus) {newWin.focus()} doesn't work in Camino. 
Tested and working in IE 6, Safari 2.04, and Firefox 2.0.0.6.

Reproducible: Always

Steps to Reproduce:
1.create basic html page.
2.create new javascript popup function with if(window.focus) {newWin.focus()}
3.view in camino, minimize pop-up window, and then click on pop-up link again. Pop-up should become focused again, but it doesn't. 
Actual Results:  
pop-up doesn't focus.

Expected Results:  
Pop-up should come to the top, focus.
(Assignee)

Comment 1

11 years ago
The summary seems much more general than the steps (and not true, in general); am I correctly understanding that the problem is specific to minimized popups?
Can we get a simple, complete testcase?
(Reporter)

Comment 3

11 years ago
Created attachment 281191 [details]
Test case

Download the zip file, and unzip. 
Place in the WebServer root, and then view the browser.
(Reporter)

Comment 4

11 years ago
I apologize for being so vague, I was in a hurry, and a bit frustrated that It wasn't working in Camino. I have attached a zip file as an example of what I am talking about. I hope that this will clarify things. 
~Becca~
(Reporter)

Updated

11 years ago
Attachment #281191 - Flags: review+
(Reporter)

Updated

11 years ago
Attachment #281191 - Flags: review+
Attachment #281191 - Attachment mime type: text/html → application/zip
(Reporter)

Comment 5

11 years ago
Created attachment 281193 [details]
Test Case
Attachment #281191 - Attachment is obsolete: true
(Reporter)

Updated

11 years ago
Attachment #281191 - Attachment is obsolete: false
(Reporter)

Comment 6

11 years ago
Comment on attachment 281193 [details]
Test Case

I goofed... Sorry.
(Reporter)

Comment 7

11 years ago
(In reply to comment #6)
> (From update of attachment 281193 [details])
> I goofed... Sorry. 
> 
 
Please ignore the second attachment...
(Reporter)

Updated

11 years ago
Attachment #281193 - Attachment is obsolete: true
(Reporter)

Updated

11 years ago
Attachment #281193 - Attachment is obsolete: false
(Assignee)

Updated

11 years ago
Summary: Javascript pop-up window: if (window.focus) {newWin.focus()} Doesn't Work. → window.focus doesn't un
(Assignee)

Comment 8

11 years ago
Updating summary to describe the specific issue.
Summary: window.focus doesn't un → window.focus doesn't un-minimize windows
(Reporter)

Comment 9

11 years ago
Just came across a site that may serve as a better example: http://www.webreference.com/javascript/960826/windows.html. Try the site in Safari, IE, or Firefox, and then take a look in Camino. 
Confirming; with the testcase, we don't un-minimize the window, and Safari and Firefox do.

Also flagging for 1.5.2 since it's a potential web-compat issue, though we may not realistically get a patch.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: camino1.5.2?
(Reporter)

Comment 11

11 years ago
Any ideas on a work around for this?  
(Assignee)

Comment 12

11 years ago
Manually un-minimize any windows you have minimized and want to use again.
(Assignee)

Comment 13

11 years ago
Created attachment 281382 [details] [diff] [review]
fix

The problem is that we are telling Gecko that minimized windows are off-screen, which isn't correct in Gecko terms.
Assignee: nobody → stuart.morgan
Status: NEW → ASSIGNED
Attachment #281382 - Flags: review?(joshmoz)

Updated

11 years ago
Attachment #281382 - Flags: review?(joshmoz) → review+
(Assignee)

Updated

11 years ago
Attachment #281382 - Flags: superreview?(mikepinkerton)
Comment on attachment 281382 [details] [diff] [review]
fix

sr=pink
Attachment #281382 - Flags: superreview?(mikepinkerton) → superreview+
(Assignee)

Comment 15

11 years ago
Landed on trunk, MOZILLA_1_8_BRANCH, and CAMINO_1_5_BRANCH (with adjustments for context diffs in the latter two).
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Flags: camino1.5.2? → camino1.5.2+
Keywords: checkin-needed → fixed1.8.1.8
Resolution: --- → FIXED
Whiteboard: [camino-1.5.2]
Target Milestone: --- → Camino1.6
You need to log in before you can comment on or make changes to this bug.