browser unexpectedly crashes during browsing some sites(especially with flash/java)

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: nardew, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; sk; rv:1.8.1.6) Gecko/20070914 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; sk; rv:1.8.1.6) Gecko/20070914 Firefox/2.0.0.6

out of the blue, browser began to crash unexpectedly. i noticed that this happens usually if there is a dynamic content on that page as flash or java. the only thing which changed between "stable" and "unstable" state is that i updated Tab Mix plus extension. I tried to disable this extension, but crashes continued. Im using default theme. The crash message is:

user@computer ~/ $ firefox-bin
No running windows found
/usr/libexec/mozilla-launcher: line 119:  2794 Segmentation fault      $(type -P aoss) "$mozbin" "$@"
firefox-bin exited with non-zero status (139)

i'm using gentoo and www-client/mozilla-firefox-bin-2.0.0.6

Reproducible: Sometimes

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
i have run into this problem with some java applets before as well.  If the crash is the browser not responding and eventually ending in a crash then its the same problem.  It doesn't seems like an extension incompatability problem so i wouldnt go disabling them.  Ive never ran into that problem with flash though...maybe you just need a flash update?  give us a link to a site that does this to you and we will try to help from there.
(Reporter)

Comment 2

11 years ago
i;m sorry, but i've been away some time.. the site where firefox surely crashes is e.g. www.rozlobennimuzi.com it's site with videos(youtube-like). just roll the page from top to below and it crashes.

Comment 3

11 years ago
no crash when i visit the site http://www.rozzlobenimuzi.com/  and i went a few pages in and still no crash.  possibly there is a problem with your extensions although i highly doubt it.  if you list out your extensions i should be able to pinpoint which one is causing problems, if thats the problem.  make sure your running the latest version of firefox.  if updating doesnt fix it and the extensions arent the problem, then the only thing i can think of is a conflict with Linux.
(Reporter)

Comment 4

11 years ago
i tried disable all extensions, but the crashes went on. but i'm begining to suspect flash library, because i found out that it always crashes if there is a flash, so java is not the place where to investigate :)

Comment 5

11 years ago
seeing as there is no crash for me it isnt a problem with firefox unless theres a conflict with linux.  unfortunately i dont know enough about linux so i cant help you there.  the only other thing i can think of is maybe your drivers?
(Reporter)

Comment 6

11 years ago
Well, im almost sure that the part which is broken is my flash plugin, because the only sites which crash are those ones with flash. So i will wait for its new version and then will report here my results. Thank you for your help.

Comment 7

11 years ago
if you think that theres a problem with your flash plugin then go to macromedia and reinstall flash.
(Reporter)

Comment 8

11 years ago
well, i've downgraded my flash plugin to version net-www/netscape-flash-9.0.48.0-r1 and everything's working now! solved. thank you for your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 9

11 years ago
no problem.  always happy to help.

Comment 10

11 years ago
my firefox keeps on erroring everytime i play shockwave...once in awhile it will error while playing flash...i play Neopets and they use alot of flash and shock wave....normaly when im playing a shockwave game it either errors and closes or it just closes on its own...this is very annoying...
You need to log in before you can comment on or make changes to this bug.