If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Google Desktop empties Thunderbird Address book

RESOLVED INVALID

Status

Thunderbird
Address Book
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Dennis Jennings, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: version 2.0.0.6 (20070728)

If I install Google Desktop, most of my Thunderbird address books are emptied - i.e. all items deleted - within minutes.  Not all address books suffer this - but most do.  It has been some time since I used Google Desktop - for obvious reasons I dare not use it - so the version of Thunderbird involved was older than that listed above.
Has this bug been fixed ?  Is it a Thunderbird or Google bug ?

Reproducible: Always

Steps to Reproduce:
1.Just install and start Google desktop
2.
3.
Actual Results:  
Install and start Google desktop.  Use Thunderbird.  Some time later, address books have been corrupted.

Comment 1

10 years ago
At least I have had Google Desktop Search installed at work for a long time, no problems with thunderbird address book.

->WFM, please don't file bugs on things you haven't even experienced (with the current stable version)... For general questions, see http://forums.mozillazine.org/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

10 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6)
> Gecko/20070725 Firefox/2.0.0.6
> Build Identifier: version 2.0.0.6 (20070728)
> 
> If I install Google Desktop, most of my Thunderbird address books are emptied -
> i.e. all items deleted - within minutes.  Not all address books suffer this -
> but most do.  It has been some time since I used Google Desktop - for obvious
> reasons I dare not use it - so the version of Thunderbird involved was older
> than that listed above.
> Has this bug been fixed ?  Is it a Thunderbird or Google bug ?
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.Just install and start Google desktop
> 2.
> 3.
> Actual Results:  
> Install and start Google desktop.  Use Thunderbird.  Some time later, address
> books have been corrupted.
> 

(In reply to comment #1)
> At least I have had Google Desktop Search installed at work for a long time, no
> problems with thunderbird address book.
> 
> ->WFM, please don't file bugs on things you haven't even experienced (with the
> current stable version)... For general questions, see
> http://forums.mozillazine.org/
> 

Now confirmed with latest version of Google Desktop and latest stable version of Thunderbird (as expected).  Corruption occurs while Google Desktop builds the initial index.  I will restore my saved address books when Google has completed the initial index - and report.

This is a very serious problem - but I have no idea if it is a Google Desktop or Thunderbird problem.


Dennis
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

10 years ago
If Thunderbird is running fine without Google Desktop, then it must be an issue in Google Desktop.
Report it to Google: http://groups.google.com/group/Google-Desktop
(Reporter)

Comment 4

10 years ago
Not necessarily.  It is most likely to be a file locking problem, and it could be either Thunderbird or Google Desktop that does not handle this properly.

I have logged a problem with Google.

Dennis

Comment 5

10 years ago
Then use the www.sysinternals.com FileMon tool to check who's doing what.

I can't replicate your bug - just downloaded Google Desktop, but running trunk.
(Reporter)

Comment 6

10 years ago
I removed Google and re-installed it and it restarted indexing.  I ran
File Monitor.

Many of my address books became corrupted in due course.  (and this
time my spelling dictionary has become corrupted - or more likely is
not visible to Thunderbird).

But in File Monitor, I could see no LOCK issued by Google Desktop on
any Thunderbird file, and I could see no instance of Thunderbird
issuing a LOCK.

Very strange!

However, at one point I clicked on one address book to be told "Unable
to Load address book file abook-41.mab. It may be read-only, or locked
by another application."  So something seems to be locking address
books at times.

I also discovered that I could not restore an address book (i.e. copy
a saved version to overwrite) that I had open (a not unreasonable
situation) - but I got no file error from Explorer when I tried to
overwrite the file.

Any guidance ?

Dennis 
(Reporter)

Comment 7

10 years ago
.........and after all that - Google Desktop does not even index the Thunderbird Address Books !

Dennis
(Reporter)

Comment 8

10 years ago
..... the problem with the spelling dictionary went away when I restarted Thunderbird.

Dennis
forums can offer good advice on restoration and such.  Ditto http://groups.google.com/group/Google-Desktop

With two people reporting WFM, it would seem to be a problem with GD (or your use of it).
=> invalid then
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.