If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Multiple GET method parameters broken at ampersand

VERIFIED DUPLICATE of bug 39281

Status

()

Core
HTML: Form Submission
P3
critical
VERIFIED DUPLICATE of bug 39281
18 years ago
17 years ago

People

(Reporter: Bob Carver, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)
BuildID:    200005 1608

If you send multiple GET method parameters separated by ampersands, everything
starting at the ampersand is garbaged. The test page shows
the problem: works in Netscape 4.72, breaks in Mozilla 2000051608.

Reproducible: Always
Steps to Reproduce:
1. Display test page at http://clues.dhs.org/private_html/test.html
2. Select the link.


Actual Results:  QUERY_STRING should be:
QUERY_STRING=hist=yes&member=xxx
but shows as:
QUERY_STRING=hist=yes%C3%AF%C2%BF%C2%BF
The second parameter is garbaged.

Expected Results:  Here is what we got: 

QUERY_STRING=hist=yes&member=xxx

Comment 1

18 years ago
reassigning
Assignee: rods → pollmann

Comment 2

18 years ago

*** This bug has been marked as a duplicate of 39281 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.