insertion of anchor should do the right thing when typing

VERIFIED DUPLICATE of bug 47687

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 47687
18 years ago
17 years ago

People

(Reporter: Brade, Assigned: Charles Manske)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
When I am typing an anchor in the edit field, I am permitted to type spaces but 
then they are automatically converted.  I think we should either not allow spaces 
to be typed or we should change the space to an underscore.  Of course we may 
need to be careful with ime stuff here.
(Assignee)

Comment 1

18 years ago
You mean convert a space to "_" as they are typing? Why don't you like the 
conversion after you finish?
(Reporter)

Comment 2

18 years ago
Yes, I mean as a person types.  I don't like the conversion after I'm done 
because it is hidden from the user (they don't know what character the space was 
converted to).
(Assignee)

Comment 3

18 years ago
I guess we can do something like we do in "ForceInteger()" to replace as they
type.
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Updated

18 years ago
Target Milestone: M17 → M19
(Assignee)

Comment 4

18 years ago
Simple fix -- replace "bad" characters such as spaces to "_" as user types and
remove the "(Spaces are not allowed)" string in the dialog.
Keywords: nsbeta3

Comment 5

18 years ago
setting to nsbeta3+
Charley, can you please add the level of priority -- thanks
Keywords: correctness
Whiteboard: [nsbeta3+]
Target Milestone: M19 → M18
(Assignee)

Comment 6

18 years ago
Named anchor issues are now tracked in bug 47687

*** This bug has been marked as a duplicate of 47687 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
verified in 8/9 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.