Text referencing Talkback in about:license should be removed

RESOLVED FIXED in Firefox 3 beta3

Status

()

Firefox
General
P5
trivial
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: AndrewM, Assigned: philor)

Tracking

Trunk
Firefox 3 beta3
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007091504 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007091504 Minefield/3.0a8pre

It is my understanding that the Talkback component has been permanently replaced by the Breakpad crash reporter. Therefore, the text on the about:license page (under 'Exceptions') pertaining to Talkback should be removed because it is no longer included. It reads:
"The Talkback crash-reporting module (Copyright ©1998-2005 SupportSoft, Inc. All Rights Reserved.)"

Reproducible: Always
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Updated

11 years ago
Flags: blocking-firefox3?

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: --- → Firefox 3 M10
(Assignee)

Comment 1

11 years ago
Created attachment 282220 [details] [diff] [review]
Paint it red, v.1

Best <del>bikeshed</del> <ins>blocker</ins> evar!

Some things to note:

* Doing this will block Camino from switching from the copy in xpfe to this copy. Almost certainly not a problem, since they are more likely to muster the resources to fix bug 380172 than they are to fix bug 368091, but there's also no reasonable way to remind them, short of filing a bug on them to switch license files, solely to mark it blocked by bug 380172.

* Gerv is of the opinion that he can make unreviewed checkins to sync the multiple copies of this file. Probably an accidental change to the "official binaries" line in the xpfe copy would be noticed, and thus an accidental change to remove that copy's Talkback line would, too. Probably.

* There is absolutely no need to do this, whatsoever. None at all. The license says "may include" not "must include, or something's wrong and you get sue and can use every bit under whatever terms you want."

* Having  a single, plural, line item under "the following portions" is just begging for grammatical bikeshedding, as would be "the following portion." I think adding something else non-Free is more likely than not, so I didn't recast it into a single sentence about the images, but I would certainly entertain (and be entertained by) a discussion of the relative merits of the two approaches.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #282220 - Flags: review?(mconnor)
(Assignee)

Comment 2

11 years ago
Gerv - note the aspersions about your character and habits in comment 1

Reed - note the opportunities for grammatical bikeshedding :)
Severity: normal → trivial
(Assignee)

Comment 3

11 years ago
Oh, and there's the Sunbird situation: they don't successfully display any license, last I looked, but they might possibly jar this one up; bug 374235 isn't entirely instructive about the current state of their switch to Breakpad.
Phil's right - we can fix this when we are good and sure that no-one's using Talkback any more. If people can get that data from all the sub-projects, then I'm fine with it.

Gerv
(Reporter)

Comment 5

11 years ago
One more thing I noticed on about:license; there is no mention of Breakpad being licensed under the New BSD License. Should there be?
AndrewM: If it's part of the build, and the license requires copies of itself to be available in "the Software" or in documentation, then yes. Please file a bug and I'll fix it.

Gerv
(Reporter)

Comment 7

11 years ago
(In reply to comment #6)
> AndrewM: If it's part of the build, and the license requires copies of itself
> to be available in "the Software" or in documentation, then yes. Please file a
> bug and I'll fix it.
> 
> Gerv

Filed bug 400520.

Updated

11 years ago
Target Milestone: Firefox 3 M10 → Firefox 3 M11

Updated

11 years ago
Priority: -- → P5

Updated

11 years ago
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Target Milestone: Firefox 3 Mx → Firefox 3 M11
(Reporter)

Comment 8

10 years ago
Fixed in bug 414025.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Attachment #282220 - Attachment is obsolete: true
Attachment #282220 - Flags: review?(mconnor)
You need to log in before you can comment on or make changes to this bug.