Closed Bug 396485 Opened 13 years ago Closed 7 years ago

Unable to quit browser (NS_ERROR_FAILURE|NS_ERROR_XPC_CANT_CREATE_WN) :: goQuitApplication

Categories

(Firefox :: General, defect, P4)

x86
macOS
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: qawanted)

Seen while testing Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8) Gecko/2007091211 GranParadiso/3.0a8.

STR:
1. I have several instances in this testing session where I am hitting this error on the Mac:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIAppStartup.quit]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goQuitApplication :: line 51"  data: no]

I even tried with a new profile and still hit this bug. During both testing runs I was running the litmus test cases related to toolbar customization. When I hit this message suddenly I could not seem to see any content and could not quit the browser. I had to force quit in order to restore everything.
I saw this tonight; so this is still with us, unfortunately (the exception's line number hasn't changed).

Might be really hard to nail this down, but we should try for Fx3 final, at least.
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P3
Target Milestone: --- → Firefox 3 M11
http://mxr.mozilla.org/mozilla/source/toolkit/components/startup/src/nsAppStartup.cpp#281 looks like the only line which can throw that error... which either means that a window is open which isn't closing, or the call to nsIDOMWindowInternal->GetClosed failed...
Priority: P3 → P4
Not blocking on this bug for final ship. Would take a safe enough patch if one comes through.
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Is this still an issue?
Target Milestone: Firefox 3 beta3 → ---
Have not seen this lately, but I have just started running the trunk more regularly since 3.5 shipped.

(In reply to comment #5)
> Is this still an issue?
[cut]
Couldn't convert chrome URL: chrome://browser/locale/quitDialog.properties
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN) [nsIJSCID.getService]"  nsresult: "0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goQuitApplication :: line 54"  data: no]
Begin mail message delivery.
End mail message delivery.
--DOMWINDOW == 75 (0xa884ae30) [serial = 302] [outer = (nil)] [url = https://bugzilla.mozilla.org/duplicates.cgi?product=SeaMonkey&format=simple]
--DOMWINDOW == 74 (0xa9473630) [serial = 125] [outer = (nil)] [url = about:blank]
--DOMWINDOW == 73 (0xa94739b0) [serial = 127] [outer = (nil)] [url = https://bugzilla.mozilla.org/show_bug.cgi?id=334872]
--DOMWINDOW == 72 (0xa94732b0) [serial = 140] [outer = (nil)] [url = about:blank]
--DOMWINDOW == 71 (0xa94755b0) [serial = 146] [outer = (nil)] [url = about:blank]
--DOMWINDOW == 70 (0xa9474cf0) [serial = 143] [outer = (nil)] [url = about:blank]
--DOMWINDOW == 69 (0xa884d130) [serial = 303] [outer = (nil)] [url = https://bugzilla.mozilla.org/duplicates.cgi?product=SeaMonkey&format=simple]
--DOMWINDOW == 68 (0xa884d2f0) [serial = 307] [outer = 0xa884ba40] [url = https://bugzilla.mozilla.org/enter_bug.cgi]
--WEBSHELL 0xac28bc00 == 32
--WEBSHELL 0xab32b800 == 31
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN) [nsIJSCID.getService]"  nsresult: "0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goQuitApplication :: line 54"  data: no]
Begin mail message delivery.
Abort mail message delivery.
An error occurred updating the cmd_sendUnsentMsgs command
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN) [nsIJSCID.getService]"  nsresult: "0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goQuitApplication :: line 54"  data: no]
Begin mail message delivery.
GetDiskSpaceAvailable returned: 92090155008 bytes
Incorporate message begin:
uidl string: 1249121558.16807.ribosome
I was testing current comm-central suite build:

Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3pre)
Gecko/20090801 SeaMonkey/2.0b2pre


Incorporate message complete.
End mail message delivery.
[cut]

I went to close using ctrl+w tabs in my browser window, that has worked. Even after no browser window was opened, I still could not quit mailer using ctrl+q nor File/Quit from the menu. Luckily, File/Close worked are shutdown the beast.

[continuing]
Begin mail message delivery.
End mail message delivery.
Begin mail message delivery.
Abort mail message delivery.
--DOMWINDOW == 23 (0xb0424b30) [serial = 83] [outer = (nil)] [url = about:buildconfig]
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN) [nsIJSCID.getService]"  nsresult: "0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goQuitApplication :: line 54"  data: no]
An error occurred updating the cmd_sendUnsentMsgs command
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN) [nsIJSCID.getService]"  nsresult: "0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goQuitApplication :: line 54"  data: no]
An error occurred updating the cmd_sendUnsentMsgs command
--WEBSHELL 0xb0417c00 == 9
--WEBSHELL 0xae25c000 == 8
Right now I see the same with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090820 Minefield/3.7a1pre ID:20090820030630

Error: uncaught exception: [Exception... "Component returned failure code: 0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN) [nsIJSCID.getService]"  nsresult: "0x80570019 (NS_ERROR_XPC_CANT_CREATE_WN)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goQuitApplication :: line 38"  data: no]
Summary: Unable to quit browser (NS_ERROR_FAILURE) :: goQuitApplication → Unable to quit browser (NS_ERROR_FAILURE|NS_ERROR_XPC_CANT_CREATE_WN) :: goQuitApplication
Duplicate of this bug: 303734
Bug 303734 has steps to reproduce.
(In reply to comment #10)
> Bug 303734 has steps to reproduce.

Given the steps I have to add that I haven't moved the whole .app away. It happened during a normal run. I don't know which steps I did to make this bug occur.
Then maybe bug 303734 isn't a dup...
I couldn't reproduce this issue following STR from Bug 303734 on Latest Nightly (2013/01/27) with different applications, because I couldn't find DeerPark app on marketplace. This is an old bug so probably it should be closed.
Please reopen this issue if anyone can still reproduce it in any way.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.