Last Comment Bug 3965 - Charset Handling-Need a pref for a default character set
: Charset Handling-Need a pref for a default character set
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All All
: P3 normal (vote)
: M9
Assigned To: Frank Tang
: Teruko Kobayashi
: Makoto Kato [:m_kato]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-18 11:50 PST by nhottanscp
Modified: 1999-08-26 12:25 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description nhottanscp 1999-03-18 11:50:51 PST
We need a pref to speficy an application level default character set.
We also need a UI for this pref.
Comment 1 nhottanscp 1999-03-19 11:22:59 PST
We used to have 'intl.character_set'. Since this requires a charset id instead
of name, we need a new one which takes a name. How about
'intl.character_set_name'?
UI should be separated from the charset menu.
Comment 2 bobj 1999-03-19 13:26:59 PST
If we do this (and I think we should), the prefs 4.5 -> 5.0migration tool will
need to handle this. Cc'ing dbragg.
Comment 3 bobj 1999-03-19 13:26:59 PST
If we do this (and I think we should), the prefs 4.5 -> 5.0 migration tool will
need to handle this.
Comment 4 bobj 1999-03-19 13:27:59 PST
If we do this (and I think we should), the prefs 4.5 -> 5.0 migration tool will
need to handle this.
Comment 5 Frank Tang 1999-04-06 15:26:59 PDT
This is depend on bug 2341. Mark it as M5
Comment 6 bobj 1999-04-26 18:05:59 PDT
For M5, we are shooting to have the charset menu, but no way to set the pref
for default charset until M6.
Comment 7 Frank Tang 1999-05-18 17:37:59 PDT
Do we really need this in M6 ??? I think it will only take me 3-4 hours to fix
this. But I am not sure why we have to have it for M6
Comment 8 Frank Tang 1999-05-19 14:40:59 PDT
change to M7
Comment 9 bobj 1999-05-28 13:41:59 PDT
Moved to M9
Comment 10 Frank Tang 1999-07-14 13:59:59 PDT
Fix and check in. Add the following line to prefs50.js to changethe default
charset to Shift_JIS

user_pref("intl.charset.default", "Shift_JIS");
Comment 11 Teruko Kobayashi 1999-08-26 12:25:59 PDT
I verified this in 8-24 Win32, Linux builds.

Note You need to log in before you can comment on or make changes to this bug.