When quitting with multiple tabs and active downloads, redundant dialogs are displayed

RESOLVED DUPLICATE of bug 404572

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 404572
11 years ago
10 years ago

People

(Reporter: Benjamin Xiao, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007091804 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007091804 Minefield/3.0a8pre

When quitting with multiple tabs and active downloads, Firefox first asks you whether you want to cancel the download to quit or dont quit. If don't quit is selected, Firefox still asks you whether you want to save tabs then quit, quit without saving, or don't quit. This is redundant. The user has already said he doesn't want to quit in the download dialog box. He/she shouldn't have to say don't quit again.

Reproducible: Always

Steps to Reproduce:
1.Quit with multiple tabs and active downloads
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007091811 Minefield/3.0a8pre

First I get the Confirm Close dialog, then I see the Downloads window on my desktop. So I can't reproduce your problem.
(Reporter)

Comment 2

11 years ago
The downloads window has to be closed. If the downloads window is still open, that means firefox is still running which means the download will continue to progress. If all windows are closed, firefox will quit and will prompt to cancel downloads. This bug is for when the download manager is closed but there are multiple tabs still open.
Ok, then I set Firefox to not show the Downloads manager (or I close the Downloads manager). In that case when exit I get a dialog with the choice "Cancel 2 Downloads" or "Don't Exit". When I click "Don't Exit" the dialog just disappears and nothing changes. I see no Confirm Close dialog in that case.
Maybe an extension is causing the problem?
(Reporter)

Comment 4

11 years ago
Well setting downloads manager to not show is not a solution, its a workaround, but many people would prefer to keep it open. You should see a confirm close dialog if you have multiple tabs open.
Dupe of 404572?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404572
You need to log in before you can comment on or make changes to this bug.