Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 396614 - Context and Dropdown Menus show up dominant monitor in multi-monitor usage
: Context and Dropdown Menus show up dominant monitor in multi-monitor usage
Status: VERIFIED DUPLICATE of bug 314279
Product: Core
Classification: Components
Component: Widget: Cocoa (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: ---
Assigned To: Josh Aas
: Markus Stange [:mstange]
Depends on:
  Show dependency treegraph
Reported: 2007-09-18 15:44 PDT by Al Billings [:abillings]
Modified: 2008-05-08 11:44 PDT (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Al Billings [:abillings] 2007-09-18 15:44:57 PDT
This has been seen on the Mac but there is no consistent repro scenario yet.

I have two monitors, an external monitor and my laptop monitor. The external monitor is the "master" monitor but Firefox is running on the laptop monitor. In this scenario, sometimes when I right click for a context menu on bookmarks or links and when I get the dropdown menu from the location bar, the menus show up on the external, main, monitor even though Firefox is running on the laptop monitor.

This has been seen off and on for the last month and a half, at least. (August and September) on Trunk nightlies. I generally see it a few times a week but haven't been able to get a repro scenario.
Comment 1 Samuel Sidler (old account; do not CC) 2007-09-18 16:16:49 PDT
See also bug 314279 which was reportedly fixed on trunk.
Comment 2 Henrik Skupin (:whimboo) 2008-03-04 15:13:29 PST
Al, does this really happen for you with current trunk builds? It should definitely be fixed by the patch on bug 314279. In that case it is a dupe.
Comment 3 Al Billings [:abillings] 2008-03-04 15:21:23 PST
It is six months later, Henrik. I haven't seen it lately.
Comment 4 Henrik Skupin (:whimboo) 2008-03-04 15:53:18 PST
If this is should still be a problem please test following:

1. Set your external monitor as the dormant monitor
2. Close Firefox
3. Remove the connector to your external monitor
4. Start Firefox (should be displayed on your laptop screen)
5. Plugin the connector (all windows should be moved to the external screen)
6. Try to open the context menu or sub menus
7. Try to move the Firefox window to your laptop screen
8. Do step 6 again.

If the menu entries are always shown at the correct screen it should be fine and we can dupe this bug against bug 314279.
Comment 5 Al Billings [:abillings] 2008-03-04 17:41:50 PST
I do this all of the time (when I'm on a laptop, which I am not at the moment). My external monitor is my dominant monitor and I unplug it while running and not running Firefox.

As I've said, I haven't seen it lately. That isn't a guarantee that it is fixed but since this bug was ignored for six months, we've had a lot of churn so I'm not surprised if it is now WFM.
Comment 6 Henrik Skupin (:whimboo) 2008-03-05 12:20:19 PST
Ok, so lets dupe it against bug 314279.

*** This bug has been marked as a duplicate of bug 314279 ***

Note You need to log in before you can comment on or make changes to this bug.