<P></P> around tables and other table oddities

VERIFIED FIXED

Status

()

P3
major
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: trever_Adams, Assigned: buster)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
<p><table>...</table></p><p><table>...</table></p> fails to add space between
two tables.  An example of this is at the above page, IF you remove the br after
the </P> of the second table (the first and second are in the same "paragraph").

Sometimes <BR> after the </table> is not needed.  Other times it wont work
unless <P></p> is around the table.  I believe that tables should NOT auto
paragraph (add space), but some times it is doing so, other times it needs all
sorts of trash.

This is true throughout the above site using 2000041811 nightly build.  The site
has been updated to end table groups with </P><BR>, but it looks very ugly.

Also, it seems that <BR> or <P><BR></P> inside of a <td></td> pair causes the
<BR> to render a HUGE amount of space... probably more than should be used.
trever_Adams@bigfoot.com - we could really do with a test case here - could you 
knock up a small HTML page showing the problem, which looks different in an 
older browser to how it looks in Mozilla, and attach it to this bug?

Thanks :-)

Gerv

Comment 2

19 years ago
Accepting bug and adding testcaes.
It seems to be that in IE and Nav4.7 <p>...</p> around a table will cause a
space before and after the table, but for some reason Mozilla totally ignores
the <p>, as shown by the testcase
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: testcase
Whiteboard: [TESTCASE]

Comment 3

19 years ago
Created attachment 8923 [details]
[TESTCASE] shows table with and without a <p>

Comment 4

19 years ago
Reassinging to Buster.
Assignee: karnaze → buster
Status: ASSIGNED → NEW
I think this should be fixed now, right?
Based on simple testcase, marking fixed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
Verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.