Closed Bug 396687 Opened 14 years ago Closed 14 years ago

Address is parsed wrong when replying to an email

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: svein, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nb-NO; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: versjon 2.0.0.6 (20070728)

When i reply to this address (from From fiels in the mail)

From: =?iso-8859-1?Q?H=F8is=E6ther=2C_Lillian?= <lillian.hoisether@subdomain.dommain.no>

then thunderbird makes TWO addresses out of it. The first one invalid and the second one valid. I always have to remove the first invalid one and that is annyoying.
The name contain norwegian special chars "Lillian Høisæther".

Reproducible: Always

Steps to Reproduce:
1. reply to a mail with the above From field.

Actual Results:  
Makes two addresses out of the one replying to - first one invalid and second valid.


Created only ONE address which is correct.
It's because of the comma. Høisæther, Lilian <email>

Duplicate of bug 254519.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254519
You need to log in before you can comment on or make changes to this bug.