Closed Bug 396694 Opened 12 years ago Closed 12 years ago

YAHOO.util.Dom.getY malfunctions

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 392671

People

(Reporter: stevee, Unassigned)

References

()

Details

(Keywords: regression)

1. New profile, start firefox
2. Go to http://futuremark.yougamers.com/forum/showthread.php?t=61573
3. Left click on a poster's name ("kup", "Table21")

Expected:
- A user info pane should appear directly under the uesrname

Actual:
- A user info pane appears, but well below the username.


Works (user info pane appears directly below username:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/2007053004 Minefield/3.0a5pre

- Broken (user info pane appears somewhere below username:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/2007053104 Minefield/3.0a5pre


Checkins to module PhoenixTinderbox between 2007-05-30 03:00 and 2007-05-31 05:00 : 

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-05-30+03&maxdate=2007-05-31+05&cvsroot=%2Fcvsroot

This problem also happens when clicking on user-names at other forums, eg: http://www.lfsforum.net/showthread.php?t=31190
Flags: blocking1.9?
Summary: User info pane appears at wrong place → User info pane appears at wrong place on vBulletin forum
(In reply to comment #0)
> 2. Go to http://futuremark.yougamers.com/forum/showthread.php?t=61573
> 3. Left click on a poster's name ("kup", "Table21")
> 
> Expected:
> - A user info pane should appear directly under the uesrname
> 
> Actual:
> - A user info pane appears, but well below the username.

To make this fail, you have to scroll the page.

That's an incompatibility with YUI, which is used there. YAHOO.util.Dom.getY returns a value which contains the scrolled offset two times.
Component: Layout → DOM
Flags: in-testsuite?
Keywords: qawanted
QA Contact: layout → general
Summary: User info pane appears at wrong place on vBulletin forum → YAHOO.util.Dom.getY malfunctions
Actually, YUI isn't used there, although it's mentioned in one of the scripts. Anyway, it's the same underlying problem.

See vB_Popup_Menu.prototype.fetch_offset in <http://futuremark.yougamers.com/forum/clientscript/vbulletin_menu.js>, which uses getBoundingClientRect if available.
Blocks: 174397
I suspect this would be fixed by the patch for bug 392671, especially since you need to scroll the page to get the bug.
Depends on: 392671
OS: Windows 2000 → All
Hardware: PC → All
This might be a duplicate of bug 392671. But your testcases confuse me a bit -- I'd say let's keep this open until it's clear that the other patch will actually fix getBoundingClientRect under all circumstances.
Component: DOM → DOM: Mozilla Extensions
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392671
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007092912 Minefield/3.0a9pre ID:2007092912
VERIFIED
Status: RESOLVED → VERIFIED
Component: DOM: Mozilla Extensions → DOM
Flags: in-testsuite?
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.