Each time I double-click a URL shortcut on my desktop, Firefox loads the URL, but the following message pops up - "Windows cannot find [add any web url here]. Make sure you typed the name correctly, and then try it again. To search for a file, click the S

UNCONFIRMED
Unassigned

Status

()

UNCONFIRMED
11 years ago
6 years ago

People

(Reporter: lorrainewelch, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Happens each time FireFox does an update and the only way to get it to work is to follow the directions below..
1. Open Explorer 
2. Select Tools and then Folder Options 
3. Select the File Types tab 
4. Select Extension: (NONE), File Type: HyperText Transfer Protocol 
5. Click Advanced toward the bottom of the window 
6. In the Edit File Type window, select open and click Edit 
7. Clear the DDE message box (which should contain "%1") 
8. Click OK, Click OK 
9. Repeat for File Type: HyperText Transfer Protocol with Privacy

Reproducible: Always

Steps to Reproduce:
1.Firefox promts that there is a software update
2.I install the update
3.Desktop shortcuts have error until I follow steps above.
Actual Results:  
Very annoying!

Expected Results:  
Would like not to have to do these steps every time I update Firefox

Updated

11 years ago
Blocks: 389502
Duplicate of this bug: 397164

Comment 2

11 years ago
This bug is a dupe of so many of the same bugs it is getting crazy. It has happened for me ever since 2.0.0.0 (maybe before). 

It is most definitely NOT fixed.... Stop closing the bugs as "verified fixed"

Every other dupe (this one included) of this bug suggests deleting the ddeexec keys from the registry entries below, but this is only a temporary fix. After your Firefox installation "auto upgrades" it breaks the registry keys again!

The problem is recreated when the upgrade adds the ddeexec keys with the (default) string value of "%1",,0,0,,,,

To fix (temporary, will break again on update or reinstall), remove the ddeexec entries from the following keys:

HKCR\HTTP\shell\open
HKCR\htmlfile\shell\open
HKCR\htmlfile\shell\opennew
HKCR\ftp\shell\open
HKCR\gopher\shell\open
HKCR\https\shell\open
HKCR\FirefoxHTML\shell\open
HKCR\FirefoxURL\shell\open

(May be more keys, but this is all I could find so far)

This is a verified issue with both Windows XP and Windows Vista (all versions)

Comment 3

11 years ago
I had the same problem and after reading trial solutions today, I went to explore in Vista Home Premium. Hit alt+T to bring up tools menu and go to search. Check "do not use index when searching" and the problem seems to be solved. Apparently, the index contains URLs from past windows searches, and this fix seems to eliminate that problem.

Comment 4

11 years ago
After closing out of everything, the same dialogs reappeared. I will have to try further remedies.

Comment 5

11 years ago
I just eliminated the ddeexec keys in the registry. The two eliminated were in HKCR/firefoxHTML/shell/open and HKCR/firefoxURL/shell/open. If the bug returns after an update, I will just delete those keys.

Comment 6

11 years ago
Bug 389502 is a tracking bug for issues related to this problem.

Comment 7

11 years ago
The "Windows cannot find 'http: " error message still pops up in the latest 
Mozilla Firefox 3 Beta 5 ( Build 2008032620 )
when you click on a short cut in Windows XP when Firefox is not running.
Component: Software Update → OS Integration
QA Contact: software.update → os.integration

Comment 8

8 years ago
Still does it in 3.6.3, Windows XP.

Updated

8 years ago
Version: unspecified → 3.6 Branch

Comment 9

6 years ago
check up ur internet port connection
You need to log in before you can comment on or make changes to this bug.