Closed Bug 396883 Opened 14 years ago Closed 14 years ago

Command-W does not close window when only one tab

Categories

(Firefox :: Tabbed Browser, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 348031

People

(Reporter: aglee, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Command-W does not close the window if "Always show the tab bar" is selected and there is only one tab.

Reproducible: Always

Steps to Reproduce:
1. Select "Always show the tab bar" in Preferences.
2. Open a new window and navigate to any web page.
3. Hit Command-W.
Actual Results:  
The tab displays an empty page.

Expected Results:  
The window should have closed, as it used to do in 2.0.0.1 and as it does when "Always show the tab bar" is not selected.  I'm forced to use Command-Shift-W in the case when there is only one tab in a window.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348031
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.