Apprunner.exe crashes at loading this URL

VERIFIED WORKSFORME

Status

()

Core
Internationalization
P3
critical
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: Teruko Kobayashi, Assigned: buster)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Tested 3-17-99 Win32 build under Windows 95J and Winnt 4.0J.

When you go to above URL, Apprunner.exe crashes.
This page uses JavaScript, but it should not crash.
(Reporter)

Updated

19 years ago
Target Milestone: M4

Updated

19 years ago
Assignee: ftang → hyatt

Comment 1

19 years ago
I don't believe this is a I18N bug. Here is the stack trace in window

nsDocument::ContentAppended(nsDocument * const 0x00e46d40, nsIContent *
0x00d8389c, int 0x00000005) line 1236
nsHTMLDocument::ContentAppended(nsHTMLDocument * const 0x00e46d40, nsIContent *
0x00d8389c, int 0x00000005) line 691
HTMLContentSink::WillInterrupt(HTMLContentSink * const 0x00e4bec0) line 1502
CNavDTD::WillInterruptParse(CNavDTD * const 0x00d65f30) line 2737 + 27 bytes
nsParser::ResumeParse(nsIDTD * 0x00000000) line 762
nsParser::OnDataAvailable(nsParser * const 0x00e473f4, nsIURL * 0x00e45510,
nsIInputStream * 0x00e43aa0, unsigned int 0x00001558) line 964 + 17 bytes
nsDocumentBindInfo::OnDataAvailable(nsDocumentBindInfo * const 0x00e45490,
nsIURL * 0x00e45510, nsIInputStream * 0x00e43aa0, unsigned int 0x00001558) line
1783 + 24 bytes
OnDataAvailableProxyEvent::HandleEvent(OnDataAvailableProxyEvent * const
0x00d6f120) line 632
StreamListenerProxyEvent::HandlePLEvent(PLEvent * 0x00d6f124) line 471 + 12
bytes
PL_HandleEvent(PLEvent * 0x00d6f124) line 476 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00b9ed70) line 437 + 9 bytes
_md_EventReceiverProc(void * 0x002a168c, unsigned int 0x0000c0f9, unsigned int
0x00000000, long 0x00b9ed70) line 799 + 9 bytes


It crash at the line :
				mWidget->Create(parent, r, nsnull, nsnull);
and mWidget is 0x000000 that time.


Reassign this to hyatt since his check in 1.39 show up the cvs blame as the last
person touch that line

Updated

19 years ago
Assignee: hyatt → rickg

Comment 2

19 years ago
Handing off to RickG.  This doesn't seem to have anything to do with XUL, so I'm
not sure why it was assigned to me in the first place.  I assume viewer would
crash on this URL as well.

Updated

19 years ago
Assignee: rickg → kipp

Comment 3

19 years ago
Kipp -- this does appear to be in nsDocument. Can you check it out?

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 4

19 years ago
1) it works in viewer without problem
2) There are zero lines of code in "nsDocument" that have the word "mWidget" in
them. So your build must have been corrupted (frank).

If you can make it crash again, please get a better stack trace (if possible) or
tell us how to reproduce it! thanks!
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
I verified this in apr0508 build.
You need to log in before you can comment on or make changes to this bug.