When classifications are in use, editproducts.cgi displays "Add product" to users that can't add products

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Administration
P2
minor
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Kevin Benton, Assigned: Frédéric Buclin)

Tracking

3.0.2
Bugzilla 3.0
Bug Flags:
approval +
blocking3.1.3 -
approval3.0 +

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
editproducts.cgi displays "Add product" to users that can't add products (those that aren't in the editcomponents group, but are in a group that can edit their own product(s)).  Rather than showing the hyperlink, I would suggest a) disabling the link or b) removing the link to prevent confusion.
Flags: blocking3.1.3?
(Reporter)

Updated

11 years ago
Severity: normal → enhancement
OS: Windows XP → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → Bugzilla 3.2
Version: 3.0 → 3.1.2
(Assignee)

Comment 1

11 years ago
Created attachment 281705 [details] [diff] [review]
patch, v1

Kevin: next time, specify that useclassifications is turned on. This would save me some time to understand which issue you were talking about. ;)
Assignee: administration → LpSolit
Status: NEW → ASSIGNED
Attachment #281705 - Flags: review?(kevin.benton)
(Assignee)

Comment 2

11 years ago
3.0 has the same issue.
Target Milestone: Bugzilla 3.2 → Bugzilla 3.0
Version: 3.1.2 → 3.0.2

Comment 3

11 years ago
This is much too trivial to be a bug.
Severity: enhancement → minor
Flags: blocking3.1.3? → blocking3.1.3-

Comment 4

11 years ago
I mean, to be a blocker. :-)
(Reporter)

Comment 5

11 years ago
Comment on attachment 281705 [details] [diff] [review]
patch, v1

I agree - looks good.
Attachment #281705 - Flags: review?(kevin.benton) → review+
(Assignee)

Updated

11 years ago
Flags: approval3.0+
Flags: approval+
(Assignee)

Comment 6

11 years ago
tip:

Checking in template/en/default/admin/products/list-classifications.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/products/list-classifications.html.tmpl,v  <--  list-classifications.html.tmpl
new revision: 1.4; previous revision: 1.3
done

3.0.2:

Checking in template/en/default/admin/products/list-classifications.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/products/list-classifications.html.tmpl,v  <--  list-classifications.html.tmpl
new revision: 1.2.2.1; previous revision: 1.2
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Summary: editproducts.cgi displays "Add product" to users that can't add products → When classifications are in use, editproducts.cgi displays "Add product" to users that can't add products
You need to log in before you can comment on or make changes to this bug.