Closed Bug 396941 Opened 13 years ago Closed 13 years ago

Menus have an unnecessary child with tag: menupopup

Categories

(Core :: Disability Access APIs, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: davidb, Assigned: aaronlev)

References

Details

(Keywords: access)

Attachments

(1 file)

It appears with the current build of FF trunk, that the menus such as File, Edit, have a single child of unknown role. I don't think we should populate the accessible tree with this node and should instead just populate the menus with their menu items (skipping the popup thingy).

This might be related to bug 396799.

Perhaps the atk menu code needs a going over; I think this might be a regression.
Perhaps it is a regression from bug 279703. It looks like the original check in was on 7/6, so look in 7/7's build.
I think this is actually caused by bug 371156 again. We were exposing anything with an ID attribute, which was a mistake.

Joanie, can you verify that this is fixed in the 9/25 build tomorrow?
Blocks: fox3access
Confirmed fixed. Thanks for assisting in confirmation MarcoZ.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.