Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 340535
11 years ago
10 years ago

People

(Reporter: Yves Goergen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

When an update was downloaded, it gets installed after Firefox is restarted. The progress window shows up and when it's gone, I get an error message telling that the upgrade failed and I should close all applications to retry. But even when I close all applications, the problem won't go away. The only chance to stop this message from re-appearing over and over again is to kill the firefox.exe process.

Today that failed because it was already gone. Instead I then immediately killed the update.exe process. Upon next start of Firefox I got the message that incremental update failed and the full version is not being downloaded. I don't want that so I quit Firefox and restarted it. Now no upgrade is done at all and I could go to mozilla.com and get that installer myself, for my local archive.

Reproducible: Always




This has happened for at least the last 2 or 3 upgrades of 2.0.0.x. It worked fine before. All on Windows XP SP2.
(Reporter)

Comment 1

11 years ago
Okay, wait, the full setup also failed but this time, it gave me an concrete error message that I could work with. It said that the file nssckbi.dll in Firefox' programme directory was locked. A search with an old tool said that Thunderbird was locking that file. So probably the error message of auto-update was correct, but also quite useless.

Maybe I should investigate Thunderbird and report a bug because it grabs Firefox files that it's not supposed to touch!

Comment 2

11 years ago
Yves, 

the version notes indicate that auto-update, "Software Update will not work if Firefox is installed to a location on your disk to which you do not have write access, since Software Update needs to replace or create files in this location."

http://www.mozilla-europe.org/en/products/firefox/2.0.0.7/releasenotes/

So, you need to make such directory not "read-only", not lecture-seule.

Gérard

Comment 3

11 years ago
Yves, 

I'm resolving this bug as a DUPLICATE of bug 340535.

If you want to install Firefox 2.0.0.7, then download it at
http://www.mozilla.com/
then manually uninstall 2.0.0.6 via Control Panel/Remove or add programs
then install 2.0.0.7 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 340535
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.