Firefox craches when parsing long page

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: Gtk
RESOLVED WORKSFORME
11 years ago
5 years ago

People

(Reporter: Fredrik, Unassigned)

Tracking

1.8 Branch
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.6) Gecko/20070731 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.6) Gecko/20070731 Firefox/2.0.0.6

A perl cgi scripts that parses log files from an external system works great with hundreds of log files. Just found one that craches firefox. (Se crash printout info in actual results)

The cgi script creates DIV and SPAN segments to colorize some parts to make the log file more readable. STYLE, DIV, SPAN, FONT etc is used. 

The page that casues the crash has nothing obvious different from other logfiles, not big not small...same basic structure as all other.

Using the same firefox binary executable it works on a Solaris 8 machine (other hardware, see additinal infomation)

I have tried with a fresh new empty firefox config(no plugins or config changes) and firefox still crashes.

The webpage works with InternetExplorer on Windows. :-|



Reproducible: Always

Steps to Reproduce:
1.Start Firefox
2.Visit the cgi script webpage and enter the specific logile.
3.Firefox craches
Actual Results:  
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  53 (X_CreatePixmap)
  Serial number of failed request:  15009
  Current serial number in output stream:  15171
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  70 (X_PolyFillRectangle)
  Resource id in failed request:  0xa003ae
  Serial number of failed request:  15012
  Current serial number in output stream:  15175


Expected Results:  
Not crashed :)

Crashes on this machine:
Sun Ultra 45 with 6.0 GB main memory and Solaris 10. 
SunOS 5.10 Generic_118833-33 sun4u sparc SUNW,A70

Same Firefox binary DO NOT crash on SAME webpage on this machine:
Sun Blade 1500 2.0 GB Solaris 8
SunOS 5.8 Generic_117350-26 sun4u sparc SUNW,Sun-Blade-1500

Feel free to contact me for more info and/or debugging or possible the cgi-script and the craching parsed logfile.

Comment 1

11 years ago
If possible (depending on what it contains), please post the logfile (compressed ?) as an attachment to this bug.

Note that there are several bugs related to allocation failures in X11, for instance bug 210931, bug 348463 ... but they seem to related to images. In your description, you didn't mention any images, but the error happens in X_CreatePixMap, so there must be one anyway. Maybe you don't have enough memory to allocate room for those images in the X Window Server ?
(Reporter)

Comment 2

11 years ago
Created attachment 281817 [details]
The webpage that crashes Firefox

This zip contains the HTML file that crashes firefox.
(Reporter)

Comment 3

11 years ago
There is no images in the file, I have added the file that causes the crash as attachment.
(Reporter)

Comment 4

11 years ago
It seams to be related to X11 yes, if I switch windowmanager to CDE it doesnt crash.

It crashes under KDE (on CDE).I use KDE 3.4.1

Is it due Firefox or KDE then...?

/Fredrik

Updated

11 years ago
Component: General → GFX: Gtk
Product: Firefox → Core
QA Contact: general → gtk
Whiteboard: DUPEME
Version: unspecified → 1.8 Branch

Comment 5

11 years ago
This bug can be reproduced under solaris under build 3.0b2pre, bug verified

Comment 6

11 years ago
(In reply to comment #5)
> This bug can be reproduced under solaris under build 3.0b2pre, bug verified
> Last time crash is due to accessiblity, 
"(Gecko:2853): libgnomevfs-WARNING **: Could not create per-user Gnome application-registry directory: /export/home/work/.gnome/application-info

(Gecko:2853): libgnomevfs-WARNING **: 不推荐的功能。不再支持用户修改 MIME 数据库。

(Gecko:2853): libgnomevfs-WARNING **: 不推荐的功能。不再支持用户修改 MIME 数据库。

(Gecko:2853): libgnomevfs-WARNING **: 不推荐的功能。不再支持用户修改 MIME 数据库。

(Gecko:2853): libgnomevfs-WARNING **: 不推荐的功能。不再支持用户修改 MIME 数据库。

(Gecko:2853): libgnomevfs-WARNING **: 不推荐的功能。不再支持用户修改 MIME 数据库。

(Gecko:2853): libgnomevfs-WARNING **: 不推荐的功能。不再支持用户修改 MIME 数据库。

(Gecko:2853): libgnomevfs-WARNING **: Cannot open '/export/home/work/.gnome/application-info/user.applications' for writing

(Gecko:2853): Pango-WARNING **: shape engine failure, expect ugly output. the offending font is 'Arial Not-Rotated 0'
段错误-核心陷阱

firefox does not crash just read this page

Comment 7

11 years ago
Add this on behalf of Jin Shi: 
WFM on Firefox 3b2, both Solaris and Linux platform. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → Core Graveyard

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.