long image left of align=right table pushes image and text down

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Brad Nixon, Assigned: buster)

Tracking

({testcase})

Trunk
Future
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description:
A 3-column table is placing the middle table under the right-hand table instead
of in between the others at the top of the page

Steps to Reproduce:
1) Screen resolution should probably be 800*600
2) load given url

Actual Results:
the middle column, with all the green text, is placed to the right of the left-
hand column as it should be, however it doesn't start until the right-hand
column finishes.

Expected Results:
Middle column should be placed at the top of the page, in between the side
columns. It should either be resized or given horizontal scroll bars on smaller
displays. (4.x resizes it without scrollbars). The current look is just odd..
the page is usable but it's not right.

Build Date & Platform Bug Found:
2000051713, Win98

Additional Builds and Platforms Tested On:
none

Additional Information:
none

Comment 1

18 years ago
This page is a html-nightmare. If you run the html validator (http:
//validator.w3.org/) on it there are a bunch of unclosed tags.

Comment 2

18 years ago
after simplifying, it looks like mozilla is more likely to be "right".
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: other → Windows 98
Summary: Misplaced table cell. → long image left of align=right table pushes image and text down

Comment 3

18 years ago
Created attachment 8890 [details]
test case

Comment 4

18 years ago
The testcase looks very identical to bug 25245. 

Comment 5

18 years ago
I'm not sure that the test case has captured the problem. It looks ok (on my 
5/25 WinNT debug build) but the url doesn't.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Comment 6

18 years ago
Now, I'm not seeing problems with the url. Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 7

18 years ago
I still see the bug under Win98, the trick is to have the window not to big, on
a 1024x768 Monitor around 800pix width should be fine. In the log I see a warning:
cell content 04643D68 has large height 66510.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

18 years ago
Ok, I see that the url doesn't look so good when the window is narrower. Nav 
even looks worse. The test case doesn't seem to capture the problem. In fact, 
Nav and IE do much worse of it than Mozilla.
Status: REOPENED → ASSIGNED
Target Milestone: M18 → M19

Comment 9

18 years ago
Buster, I'm not sure if this is a bug or not. Should the right aligned table 
cause the body to get wider and hence make the page look better, or are we doing 
the right thing by limiting things to the viewport width.
Assignee: karnaze → buster
Status: ASSIGNED → NEW
(Assignee)

Comment 10

18 years ago
all P3 bugs are Future, will not make RTM of NS6.
Status: NEW → ASSIGNED
Target Milestone: M19 → Future

Comment 11

17 years ago
QA contact update
QA Contact: chrisd → amar

Comment 12

17 years ago
WFM win98 2001080603 . Amar, could you please verify? 

Thanks

bernd
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 13

17 years ago
 works fine for me.. or this bug is invalid.. Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.