RSS preview leaks XBLDocGlobalObject

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: sayrer, Unassigned)

Tracking

({memory-leak})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Steps to reproduce
==================

1.) start browser
2.) navigate to http://scripting.com/rss.xml
3.) quit browser
(Reporter)

Comment 1

11 years ago
Created attachment 281842 [details]
leak analysis
So I'm confused by this.  The XBL code cyclec collector traverses the nsJSContext.  That should traverse the JSContext and hence its global, right?  And that should traverse the xbl global (since PRIVATE_IS_ISUPPORTS is set on the JSClass).  So this should be getting cycle-collected.  How come it isn't?
(Reporter)

Comment 3

11 years ago
This is fixed by the patch in bug 397804.
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.