Disk cache directory not being recreated after it's deleted

VERIFIED FIXED in M17

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: cks+mozilla, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] fix in hand)

(Reporter)

Description

19 years ago
Build ID: 2000051720 (and current CVS pull, too)

 If you delete the Mozilla disk cache directory (which is normally in
$HOME/.mozilla/<profile>/Cache), perhaps as the brutal and fast Unix
way of cleaning it out, Mozilla will not recreate it. As a side effect,
Mozilla stops using a disk cache.

 Reproduction is 100% for me.

Reproduction:
- cd to your profile's directory ('cd $HOME/.mozilla/*/.' may work)
- delete the disk cache with 'rm -rf Cache'.
- start Mozilla, browse around, exit.
- verify that the Cache directory has not reappeared and thus you are
  not using a disk cache.

Comment 1

19 years ago
It's being recreated fine on my may 11th linux build.

Comment 2

19 years ago
I am running Mozilla build 2000060409 on Linux right now.  I'm getting this same
bug. I'm not sure when the Cache appears at all.  I'm moving this to New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

19 years ago
*** Bug 40235 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

19 years ago
Nominating for nsbeta2
Assignee: gordon → neeti
Keywords: nsbeta2
(Assignee)

Updated

19 years ago
Target Milestone: --- → M17

Comment 5

19 years ago
Putting on [nsbeta2-] radar.  Will release note for beta2 not to do this :-)
Whiteboard: [nsbeta2-]
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

19 years ago
*** Bug 42856 has been marked as a duplicate of this bug. ***

Comment 7

19 years ago
I propose this should be reassessed. Removing the cache directory to clean out 
the cache is a common enough process. Plus we have the fix in hand. Clearing 
minus for reeval. 
Whiteboard: [nsbeta2-] → fix in hand

Comment 8

19 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: fix in hand → [nsbeta2+] fix in hand
(Assignee)

Comment 9

19 years ago
Checked in a fix
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 10

19 years ago
verified:
Linux 2000071008
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.