Last Comment Bug 397188 - FCK Editor no longer working on Firefox trunk
: FCK Editor no longer working on Firefox trunk
Status: RESOLVED FIXED
fixed by 383682
: regression, verified1.8.1.13
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Blake Kaplan (:mrbkap)
:
:
Mentors:
http://www.fckeditor.net/demo
Depends on: 383682
Blocks: 382509
  Show dependency treegraph
 
Reported: 2007-09-22 12:59 PDT by Biju
Modified: 2008-03-14 17:18 PDT (History)
8 users (show)
dveditz: blocking1.8.1.13+
bob: in‑testsuite-
bob: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Biju 2007-09-22 12:59:51 PDT
http://www.fckeditor.net/demo not working

Gets following error message

Error: FCKeditorAPI has no properties
Source File: http://www.fckeditor.net/fckeditor/editor/js/fckeditorcode_gecko.js
Line: 37
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-09-22 13:54:29 PDT
Regression range:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&branch=HEAD&branchtype=match&date=explicit&mindate=2007-06-04+03%3A00&maxdate=2007-06-05+06%3A00

Most likely a regression from bug 382509 (see also bug 390859 and bug 394073).

The editor code from that page is an iframe that points to http://www.fckeditor.net/fckeditor/editor/fckeditor.html, which dynamically loads http://www.fckeditor.net/fckeditor/editor/js/fckeditorcode_gecko.js , which does call eval to define "FCKeditorAPI".
Comment 2 Blake Kaplan (:mrbkap) 2007-10-08 16:49:25 PDT
The patch in bug 383682 fixes this for me.
Comment 3 Blake Kaplan (:mrbkap) 2007-12-19 16:50:47 PST
This now works for me. Marking fixed as a result of bug 383682.
Comment 4 Bob Clary [:bc:] 2007-12-21 11:58:48 PST
covered by the tests referenced in bug 383682
Comment 5 Samuel Sidler (old account; do not CC) 2008-03-07 10:27:46 PST
Fixed on the branch in bug 382509.
Comment 6 Al Billings [:abillings] 2008-03-14 17:01:44 PDT
How was this broken in branch in the first place? Pre-patch, the FCKeditor is working fine (as it is after the patch). I compared 2.0.0.12 and 2.0.0.13rc1.
Comment 7 Samuel Sidler (old account; do not CC) 2008-03-14 17:05:25 PDT
Al: It's not. There were several bugs that were regressions from bug 382509. We need to make sure those regressions don't exist.
Comment 8 Al Billings [:abillings] 2008-03-14 17:18:35 PDT
After speaking to SS, this is clearer. No regressions caused with the editor. Verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/2008031114 Firefox/2.0.0.13.

Note You need to log in before you can comment on or make changes to this bug.