If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot use menu bar while page is loading.

VERIFIED WONTFIX

Status

Camino Graveyard
Toolbars & Menus
VERIFIED WONTFIX
10 years ago
10 years ago

People

(Reporter: chmeeedalf, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.6) Gecko/20070809 Camino/1.5.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.6) Gecko/20070809 Camino/1.5.1

While loading a website I cannot use the menubar.

Reproducible: Always

Steps to Reproduce:
1. Load a web page.
2. While loading, click in the menubar
3.
Actual Results:  
Click is ignored until page is loaded, then clicked menubar item is opened.

Expected Results:  
Menu bar should be responsive (another thread from the rendering thread?)

Comment 1

10 years ago
If you are loading a complex page, then there can be periods where we don't get to service the event loop as often as we would like to, but it's certainly not the entire length of every page load. To the extent that this happens though, it's not feasible for us to fix it; page rendering cannot be run on any but the main thread, and we have no control over Gecko returning to the event loop faster.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Updated

10 years ago
Status: RESOLVED → VERIFIED

Updated

10 years ago
Duplicate of this bug: 400936
You need to log in before you can comment on or make changes to this bug.