Startup of browser takes 2-5 minutes

RESOLVED INCOMPLETE

Status

()

Toolkit
Startup and Profile System
RESOLVED INCOMPLETE
10 years ago
9 years ago

People

(Reporter: miran, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-04-25)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007092105 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007092105 Minefield/3.0a8pre

Beginning about two updates ago, starting Minefield began to take minutes.  I load to a blank page.  Bookmark files is just over 1Mb, it's one I've been using for years.  I used the old profile.

AMD Athlon 64x2 Dual 4800+ 2.41 GHz
3GB RAM 

Large HD, currently in 2 sectors & only using one @ about 425GB. I'm using about 236GB of that, so just over half. I've defragged within the last two days.

Reproducible: Always

Steps to Reproduce:
1. Click on the icon to start Minefield.
2. Wait.
3.
Actual Results:  
It will load and work just fine, but it takes 2-5 minutes to actually start the program.

Expected Results:  
It used to load in under 15sec, usually less.

Littlemutt from the forums suggested that it might be the dual cpu.

I rebooted, started Minefield, ran through the above steps [set the affinity to one cpu], and Minefield came up in about 6 seconds, possibly less.

I've had this computer for a while now, and never had this problem with Minefield before. The fix seems to work, but it doesn't explain what the problem is.

yet more info:
the affinity selection is good for one session only
I exited Minefield, and then restarted and the program popped right up in about one second (I start with a blank page). I checked the affinity and both cpu-s were checked.

further checking:
I need to reset the affinity to one cpu after EVERY reboot to get a fast startup.  The 'fix' is lost every time I reboot.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit

Comment 1

9 years ago
miran do you still see this problem?
Keywords: perf
Whiteboard: closeme 2009-04-25

Comment 2

9 years ago
=> incomplete due to no response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.