Arrow heads not shown in a particular SVG graph

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
11 years ago
8 years ago

People

(Reporter: lapsap7+mz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
Created attachment 282118 [details]
Original SVG file from Wikipedia

I've just come across this SVG:
http://upload.wikimedia.org/wikipedia/commons/c/c2/Vector_field.svg (attached file #1)

Wikipedia's PNG rendered image of the same SVG shows that inside the graph, there are arrows instead of segments:
http://en.wikipedia.org/wiki/Image:Vector_field.svg

I've opened the same SVG file in "Inkscape 0.45.1" as well as Adobe's "SVG viewer" inside IE and indeed these two softwares also show arrows instead of segments.

An image containing the comparison will be uploaded as well (attached file #2).

With my limited SVG knowledge, I've made a reduced test case (attached file #3) which contains only one arrow.
(Reporter)

Comment 1

11 years ago
Created attachment 282119 [details]
Comparison of what should be rendered and what is rendered
(Reporter)

Comment 2

11 years ago
Created attachment 282120 [details]
Test-case
(Reporter)

Comment 3

11 years ago
For me, it happens in Firefox 2.0.0.6 and 2.0.0.7 in WinXP Pro.
Works in the current trunk so will be fixed when Firefox 3.0 comes out.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

11 years ago
Normally the resolution should be fixed as FIXED, not WORKSFORME, since it's perfectly reproducible in release version.
Resolution: WORKSFORME → FIXED
Fixed means fixed in the trunk by a particular check in.

Works for me means fixed in the trunk by an unknown check in.
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 7

11 years ago
Ahem, you should read the doc:
https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution

If you don't agree, you could always go to https://bugzilla.mozilla.org/show_bug.cgi?id=385520 and express your opinion.

For the time being, this bug won't be marked as WORKSFORME.
Resolution: WORKSFORME → FIXED
That may be the way the bugzilla authors suggest the fields are used, but it's not the way it's typically being used, certainly not by the SVG developers. We would like to be able to distinguish between bugs that we have genuinely fixed with known checkins, and bugs that disappeared and should perhaps be revisited at some point in the future to ensure they don't live on in some hidden form.

If I understand correctly, the only reason to use Dave Miller's definitions is so that reporters don't get offended. Hopefully if now understand our system you would not be offended. If that's the case, would you mind us using our current system, at least until a WORKSNOW (or whatever) value is added? It does have value for us.
(Reporter)

Comment 9

11 years ago
I'm not offended by the word "works for me", but by its implication: the bug is not reproducible (ie I'm nut, this bug never existed).

But, in all common senses, first, this bug is reproducible; secondly, and most importantly, at this very moment (26 October 2007) with the only available version of Firefox (ie 2.0.0.8), it DOESN'T work for me.  So, the resolution of WORKSFORME is purely and simply illogical.
The text is "works for me", for which your interpretation seems to be "works for me, always worked for me, and I can't see how this nut ever thought it didn't work". I'm saying that is not our interpretation of the text. Our interpretation of "works for me" is "works for me now in the latest code, so the bug seems to have disappeared (investigation why later?)". Neither interpretation is more valid than the other, but if you understand the interpretation used by the devs is the latter, there's no need to be offended.

I'm just asking, if you understand our interpretation and thus are not offended, could we continue to use our interpretation for now please. Otherwise you break our system.

Comment 11

11 years ago
Agreed.  WORKSFORME is a very specific QA connotation.  Using something different, even if that "makes sense" in natural language, breaks the system.  Just because it is marked as WORKSFORME does not mean that it was never broken.  It just means that it's working now, in the latest builds, and we don't know what fixed it.  Anybody using the system needs to play by the system's rules. :)
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 12

11 years ago
Sorry but I have to play the resistance.

Yes, exactly because anybody using the system needs to play by the system's rules, and the system rules (not your rules) tell us that we have to use FIXED in this case.

I'm sorry to hear that you've used the b.m.o system wrongly all these time.  But it's not because you've done it wrong that the others have to pay the price!  As I've written in the other bug taking an emergency door as an example, it's not because lazybones tend to use emergency door and leave it open that every emergency door in the world has to change its role from a real emergency door to a common door.

It's not by creating confusion that you improve something.  This incident exactly reminds me of what Microsoft has been doing these years.  It's got to use some standards.  But it found that something in that system doesn't suit its needs, so it *workarounds* it by creating its own modified version.  So, in the end there're two versions in the world: the original one and the MS-specific one.

Is this really what you want to accomplish?
Resolution: WORKSFORME → FIXED
Jason: please leave the status as Seak has set it. I don't think trying to reason further is worth the time or effort.

Updated

8 years ago
Status: RESOLVED → VERIFIED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.