infinite loop while charset conversion

VERIFIED FIXED in M16

Status

P3
normal
VERIFIED FIXED
19 years ago
11 years ago

People

(Reporter: nhottanscp, Assigned: nhottanscp)

Tracking

({verifyme})

Trunk
verifyme

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][6/01])

Attachments

(1 attachment)

(Assignee)

Description

19 years ago
This is discovered by Rich but has no reproducible procedure.
But this should happen whenever it gets corrupted data (e.g. charset mislabeled 
messages).
Quoting from the mail,
> I have a problem with the nsMsgI18NConvertToUnicode() routine getting
> stuck in an infinite loop. The problem looks like:
> 
>           res = encoder->Convert(currentSrcPtr, &srcLength, localbuf,
> &dstLength);
> 
> Is returning ZERO as the dstLength, but the res is set to
> NS_OK_UDEC_MOREINPUT so you never get out of the loop.
(Assignee)

Comment 1

19 years ago
Created attachment 8837 [details] [diff] [review]
patch
(Assignee)

Comment 2

19 years ago
Put nsbeta2 to keyword.
This is a safe fix (added an extra condition to break the loop), r=rhp.
Status: NEW → ASSIGNED
Keywords: nsbeta2
Target Milestone: --- → M16

Comment 3

19 years ago
Putting on [nsbeta2+][6/01] radar.  This work must be done by 06/01 or we may 
pull this for PR2.
Whiteboard: [nsbeta2+][6/01]
(Assignee)

Comment 4

19 years ago
checked in the patch
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
I can't verify this.  adding verifyme keyword
Keywords: verifyme
(Assignee)

Comment 6

19 years ago
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.