relative links in a frame not using the entire url in the href of the BASE tag

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Jim Hart, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

The URLs for links that show up in the lower right frame after a search are incorrect. The page appearing in the frame has a <BASE...> tag, but relative URLs aren't resolved correctly. When the same page is displayed in a page without frames, the links are resolved correctly. See the Steps to Reproduce.

Reproducible: Always

Steps to Reproduce:
1 - load the URL that demonstrates the problem
2 - In the box in the top frame, type the word "Psychology" and press RETURN.
3 - After the lower right frame fills in, note the URLs for any of the links in the "Title" column by rolling the mouse over them. They are of the form: http://libraries.maine.edu/item.aspx?id=2645
4 - View the frame source for the lower right frame and note the URL in the <BASE...> tag. It should be: http://libraries.maine.edu/maineserials
5 - Also note that the hrefs for the links of the items in the Title column in the source code are of the form: href="item.aspx?id=2645"

Note that the resolved URLs (as shown in step 3) are incorrect.

Actual Results:  
The links give a 404 error because they look like:

http://libraries.maine.edu/item.aspx?id=2645

Expected Results:  
The links in the Title column should look like:

http://libraries.maine.edu/maineserials/item.aspx?id=2645

Prepended the entire <BASE...> href (and a slash) in front of the relative URLs.
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.