subscribe performance problems

VERIFIED FIXED in M17

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

type down and population on large servers (news.mcom.com and news.supernews.com)

is really bad, not even usuable.
it's usable with news.mozilla.org, and autosubscribe works, so this isn't a
dogfood blocker.

but it is bad for nsbeta2
Status: NEW → ASSIGNED
Keywords: nsbeta2
Summary: subscribe performance → subscribe performance problems
Target Milestone: --- → M17
checked in one thing, using HasAssertion() and GetTarget() to make population
faster.  I'm thinking that I might need to move away from the in memory
datasource to really get the performance.  it works well for small servers, but
news.mcom.com or news.supernews.com is pretty bad.
  
building up the entire datasource is killing me, but if I had my own, I could do
things lazily.

the alternative would be to use the in memory datasource, and only assert
children when I need to, based on what the users clicks or what the user types
in type down.

Updated

18 years ago
Keywords: perf

Comment 3

18 years ago
Putting on [nsbeta2-] radar. 
Whiteboard: [nsbeta2-]

Comment 4

18 years ago
How bad is this really?

Updated

18 years ago
QA Contact: lchiang → laurel

Comment 5

18 years ago
We have another typedown bug somewhere that is nominated for nsbeta3.  I have to 
find it.

Comment 6

18 years ago
*** Bug 39171 has been marked as a duplicate of this bug. ***
a while ago I fixed type down to be much better.

we do a binary search instead of a linear search.

marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
Marking verified, much improved. Nov22 commercial build.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.