Loading frames using Javascript fails miserably

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
major
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Christoph Sold, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m16) Gecko/20000517
BuildID:    2000051720

starting on the above mentioned URL, klick any topic at the top.
On both IE and NS, a menu is shown. Mozilla drops out of the frameset and
displays a single page.

Reproducible: Always
Steps to Reproduce:
1. http://www.flex-tools.com/en/index.htm
2. Click >>Products<<


Actual Results:  The frameset is gone.

Expected Results:  A products menu should appear in place of the >>Products<< label.

Here's some individual URLs to get into the picture...
1) Frameset: http://www.flex-tools.com/en/index.htm
<frameset rows="133,*" border="0" framespacing="0">
<frame src="navi_start.htm" name="navi" marginwidth="0" marginheight="0"
frameborder="NO" bordercolor="#999999" scrolling="NO">
<frame src="subframe.htm" name="sub">
</frameset>

Comment 1

18 years ago
 I can confirm that this also happens under Linux with a current CVS
pull/build. (I'm not changing the Platform/OS to All/All since I'm
not sure of the etiquette for that, and I don't have a Mac to check
there too.)

Comment 2

18 years ago
Sorry for the delay - taking over QA for the JavaScript Engine group -

Can confirm bug is still occurring on both Linux and WinNT
Using: Mozilla debug Linux and Windows builds made on 06/21/00, 06/20/00 resp.

However, this doesn't seem like a JS Engine issue, but a browser issue.
Reassigning to Browser-General. Again, apologies for the delay -
Assignee: rogerl → asa
Component: Javascript Engine → Browser-General
QA Contact: pschwartau → doronr

Comment 3

18 years ago
over to DOM
Assignee: asa → jst
Component: Browser-General → DOM Level 0
QA Contact: doronr → desale
(Assignee)

Comment 4

18 years ago
Huh, works just fine here, tested on Linux, please reopen if this is still a
problem. Marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
verfied on win98
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.