browser buster shows history/meta refresh pretty broken

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: chofmann, Assigned: jud)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+], URL)

(Reporter)

Description

19 years ago
linux 0518 build

go to test url.
page gets reloaded by only the first site shown in the rotation
ever gets displayed.

hit back/reload buttons and it goes to the correct site in the rotation
then at the next refresh it returns to the first site shown.

this will most likely a dup of other bugs that are already filed
but I wanted to make sure...
(Assignee)

Comment 1

19 years ago
handing to pav. this is looking timer related.
Assignee: valeski → pavlov

Comment 2

19 years ago
I tried a build from before I checked in and this is still happening.  
Reassigning back to valeski.
Assignee: pavlov → valeski
(Reporter)

Updated

19 years ago
Keywords: nsbeta2

Comment 3

19 years ago
Need more info.  Is this only happening on the test URL?  
Whiteboard: [NEED INFO]
(Reporter)

Comment 4

19 years ago
its a pretty simple test case.  I think my.netscape.com uses the
same type of refresh scheme.  If you went to your my.netscape.com
custom page (or maybe even the default page) and you never saw 
any new content changes from the first page that you viewed
then you might be observing the same problem.

Comment 5

19 years ago
Could we get a retest on this?

Comment 6

19 years ago
Claudius, could you test this.

Comment 7

19 years ago
with the browser buster page:
pretty much just as chofmann reported. With the 2000060208 Build on Win98 the main frame never changes on meta-refresh. If 
you reload however you get the correct page in the sequence - only to return to the old one upon refresh.

with a my.netsape.com custom page:
Inconclusive.
This page only updates every 5min., ..., 20 minutes later it seemed to be behaving correctly.
On the one hand, the main frame seemed to update  when the top frame refreshed. I sent myself webmail inbetween refreshes 
to see this.

On the other hand, I do note that my news headlines were timestamped and 3+ hours old and never changed while I tested this. 
Netcenter claims these headlines are updated hourly yet mine were stamped 2:58pm while the top frame quoted the time as  
6:17pm.

Comment 8

19 years ago
putting on beta2 plus radar
Whiteboard: [NEED INFO] → [nsbeta2+]
(Assignee)

Comment 9

19 years ago
I can't repro this on NT. Is this a Win95/98 problem only?

Comment 10

19 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 11

19 years ago
Hmmm, I've checked with the 2000060613 builds on WinNT and Win98 and this seems to work just fine now.(Before, I repro'd it 
w/Win98) 
(Assignee)

Comment 12

19 years ago
gone
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 13

19 years ago
VERIFIED wfm
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

18 years ago
*** Bug 39031 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.