SVG text with font-family Arial is rendered in italic

RESOLVED DUPLICATE of bug 327522

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 327522
11 years ago
11 years ago

People

(Reporter: Teun van Eijsden, Unassigned)

Tracking

1.8 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Firefox/2.0.0.7 for MacOS X

When using font-family: Arial on a <text/> in svg, the text is rendered in italic.

Reproducible: Always

Steps to Reproduce:
1. Create an svg
2. Make some text in it: <text style="font-size: 90pt; font-family: Arial" x="100" y="400">Arial</text>
3. View in Firefox on Mac OS X
Actual Results:  
The word 'Arial' appears in italic

Expected Results:  
The world 'Arial' appears in a normal, non-italic font.

Notice the Case-sensitivity, as also displayed in the attached example svg file.
(Reporter)

Comment 1

11 years ago
Created attachment 282544 [details]
SVG file which displays text with font-family Arial

This svg file displays text with several font-families.
On Mac OS X the second line is rendered in italic
Notice the case-sensitivity
Component: General → SVG
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 1.8 Branch
duplicate of bug 327522 perhaps?  Can you retest with a trunk build please?
(Reporter)

Comment 3

11 years ago
Duplicate of 327522
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 327522
You need to log in before you can comment on or make changes to this bug.