Back-button after submitting forms loads wrong page

VERIFIED WORKSFORME

Status

()

P3
minor
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: yann.schlame, Assigned: radha)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [de] (Win98; I)
BuildID:    2000041805

When a cgi-script using the "post" method is used in a form, and a page is 
automatically loaded after submitting the form, then continueing to browse and 
then clickung "Back" leads to the URL of the script, not to the autoloaded page.

Reproducible: Always
Steps to Reproduce:
1. got to http://try.fdisk.de/yps/quiz/lw.htm
2. Click on the Submit-Button (it's actually called "Absenden", as it's a german 
page)
3. on the "Vielen Dank"-Page that should now appear, follow any of the links 
("Startseite", "Star Trek-Quiz", ...)
4. click the browsers back-button

Actual Results:  The servive that provides the autoload of the "Vielen 
Dank"-Page gives an "Error: ... [unconfigured]: Formular nicht korrekt 
konfiguriert (unknown)"-Message



Expected Results:  return to the "Vielen Dank"-page

Don't worry about sending the form, as it's on my own homepage. I don't have a 
counter on that quiz-page, so this is NO attempt to get more hits on my 
homepage.
But please don't spam me with too many sent forms, ok? :)
(Problem should probably be reproducible with any form autoloading a new page 
after submitting, but I only tried it on my own homepage).
The same problem occoured with Netscape 6 PR.
Netscape 4.7 and IE 5.0 behave as expeceted, they return to the "Vielen 
Dank"-Page.

Comment 1

19 years ago
WORKSFORME linux may 11th build. will test with latest win98 tomarrow.

Comment 2

19 years ago
eric, I don't know if this is yours, but maybe you know who to send it to.
Assignee: rods → pollmann

Comment 3

19 years ago
Sounds like a duplicate of bug 17685.

Comment 4

19 years ago
Radha, can you check to see if this is a duplicate?  Thanks!
Assignee: pollmann → radha

Comment 5

19 years ago
tested on Win95 2000060708 build works for me. 
yann.schlame@gmx.net can you get the latest build to test.
Eric, i don't know if it was a dupe, but data in the form show on back and it 
all goes to the right place :)

yann.schlame@gmx.net reopen if you still see or have more info.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 6

19 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Comment 7

18 years ago
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101214 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.