Closed Bug 39785 Opened 22 years ago Closed 19 years ago

ftp symbolic links are displayed using document icon

Categories

(Core :: Networking: FTP, defect, P3)

x86
Windows NT
defect

Tracking

()

RESOLVED DUPLICATE of bug 133835
Future

People

(Reporter: tever, Assigned: bugs)

References

()

Details

Overview Description:  Some of the folders on this site are showing a document 
icon.

Steps to Reproduce:
1.)  Go to the ftp site above

Actual Results:  document and folder icons mixed

Expected Results:  I was expecting to see all folder icons as I do in 4.7x

Build Date & Platform Bug Found:
NT 2000051808

Additional Builds and Platforms Tested On:
also on linux
The items that are displaying the document icon are symbolic links, which may 
point to directories or may point to documents (you can't tell with the standard 
form for ftp's "DIR"). So, the choice to use a document icon vs. a folder icon 
is stylistic. I suppose one could choose to create a "symlink" icon for this 
purpose. At any rate, this is not a toolkit bug. Passing to rjc, as I think he 
has had a hand in directory.xul. Apologies if this is the wrong choice.
Assignee: trudelle → rjc
Component: XP Toolkit/Widgets → XPApps
Summary: Some ftp folders are displaying document icon → Some ftp folders are displaying document icon
yeah, I was just going to add a comment that these were symbolic links.  So, 
should they display a folder or document icon?  4.7 shows folders.  
This sounds like a good job for Ben.  :^)
Assignee: rjc → ben
you realise that by assigning this to me, it will never be fixed. 
nav triage team:

And it will continue to be not fixed. Marking nsbeta1-
Keywords: nsbeta1-
Changing summary to "ftp symbolic links are displayed using document icon" better 
reflect bug
Summary: Some ftp folders are displaying document icon → ftp symbolic links are displayed using document icon
Marking nsbeta1- bugs as future to get off the radar.
Target Milestone: --- → Future
See also bug 24389 (but this isn't a dup).
Status: NEW → ASSIGNED
Has this been changed? Using a site like
ftp://angus.ind.wpi.edu/pub/packages/isc/dhcp/ symbolic links are displayed as
folders.

WFM?
wow. very lost bug.

*** This bug has been marked as a duplicate of 133835 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Component: XP Apps → Networking: FTP
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.