Star menu should require interaction to close

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
11 years ago
9 years ago

People

(Reporter: BijuMailList, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
D is the next letter to F in keyboard.
So when I try to do ctrl + F, 
my fat finger accidentally it D and make it as ctrl + D
which add current page to bookmark, without conforming with me.
this is really irritating

Also when you want to pull down URL list menu
the "star" is next to it and creates unwanted bookmarkes

Comment 1

11 years ago
Yeah, it's weird that (Ctrl+D, Esc) adds a bookmark.  I'm used to (Ctrl+D, Enter) adding a bookmark and (Ctrl+D, Esc) canceling out of adding a bookmark.
Summary: Bookmark creation without user conformatation → Too easy to create bookmarks accidentally (and without confirmation)
OS: Windows XP → All
Hardware: PC → All

Comment 2

11 years ago
Biju, the icon is now moved over a few pixles and not touching the drop down menu so this should alleviate that problem.  With the dialog up just hit delete (called delete for now) to not save the bookmark.

Jesse, the Esc key not canceling is bug 396513

Updated

11 years ago
Duplicate of this bug: 405973

Comment 4

11 years ago
Both of these bugs are due to it being easy to dismiss the star menu. This seems to be an intentional design however reading the bug in comment 2.
Flags: blocking-firefox3?
Summary: Too easy to create bookmarks accidentally (and without confirmation) → Star menu should require interaction to close
(Reporter)

Comment 5

11 years ago
Why Summary was changed 

From => Too easy to create bookmarks accidentally 
        (and without confirmation) 

To   => Star menu should require interaction to close

this dont reflect the original issue, 
ie firefox doing things with out asking user confirmation
(Reporter)

Comment 6

11 years ago
(In reply to comment #4)
> Both of these bugs are due to it being easy to dismiss the star menu. This
> seems to be an intentional design however reading the bug in comment 2.

Then this bug should modified to make it as a RFE

I will be happy if I can get a boolean about:config item something like
   browser.places.star.instantApply 
ie, similar to suggestion at bug 396513 comment 3
That would break the design because the dialog doesn't allow for a "cancel" button or the like. What will people see in the add bookmark dialog if this value is set?
I think that this is a WONTFIX, tbh, I'll let mconnor decide.
Yeah, its a WONTFIX, we're not going to add extra codepaths to an already complex piece of code.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking-firefox3?
Resolution: --- → WONTFIX

Updated

11 years ago
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.