If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Host a git mirror of hg.mozilla.org

RESOLVED WONTFIX

Status

mozilla.org Graveyard
Server Operations
--
enhancement
RESOLVED WONTFIX
10 years ago
3 years ago

People

(Reporter: Julien "_FrnchFrgg_" RIVAUD, Assigned: aravind)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.6) Gecko/20070723 Iceweasel/2.0.0.6 (Debian-2.0.0.6-1)
Build Identifier: 

There are some third-party git repositories that mirror hg.mozilla.org/cvs-trunk-mirror, but they aren't always up and reliable.

It would be cool for people more familiar to git (or like me who cannot seem to adapt to mercurial) to have a (bare) git repository which would track the mercurial repository.

Perhaps you could use the hg-fast-export tool available here: http://repo.or.cz/w/fast-export.git (I currently use it locally)

Or perhaps the way you export the CVS checkins to mercurial can be extended to git (but then it would be a temporary solution, when you eventually switch to hg for the main repository, git will have to import directly from hg)

Reproducible: Always

Steps to Reproduce:
# git clone git://git.mozilla.org/cvs-trunk-mirror.git

or 

# git clone http://git.mozilla.org/cvs-trunk-mirror.git
Actual Results:  
git.mozilla.org doesn't exist

Expected Results:  
Everything works ! Yippeee !
(Reporter)

Updated

10 years ago
Component: CVS: Administration → Server Operations
(Reporter)

Comment 1

10 years ago
Sergey Yanovich (http://git.aasii.org/, ynvich@gmail.com) currently hosts a mirror, maybe its config can be used to setup the official mirror...
(Assignee)

Updated

10 years ago
Assignee: server-ops → aravind
(Assignee)

Comment 2

10 years ago
Brendan:  Do we want to add git to the mix of VC systems we already have?

I personally wouldn't want to, anyone willing to use git could probably update their local mirror using some kind of sync tool and pull/push to that.

If enough people can't live without it, we could probably add it.

Comment 3

10 years ago
For the time being we should stick to Hg and leave git mirroring to the community if they feel the need.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

10 years ago
Yeah. This bug is just about hosting a public read-only git mirror of the Hg repo, because if hosted by mozilla, the git mirror would be more reliable.

Doing the conversion locally can be an option, but a poor one (I am currently using this solution when the aforementionned git mirror is down or not enough up to date)
jst uses git, doesn't seem to feel the need for a git.mozilla.org mirror of some sort. Cc'ing him in case he can give advice so others can feel likewise.

/be
I don't really have any good advice here, as what I do myself is pretty clunky and I'd rather not share that since there's better ways to do things now.

I personally don't feel the need for a git mirror. And if we were to set one up, it should be a mirror of mozilla-central, not cvs-trunk-mirror as what you get from cvs-trunk-mirror isn't enough to build mozilla from as is, so to make that useful we'd need to invest more time into yet another repo that someone needs to maintain etc. Once mozilla-central becomes more active and main development moves over to it, I could see us hosting a readonly copy if there's enough demand, but given that it's readonly, I sort of doubt there will be that much demand...
(Reporter)

Comment 7

10 years ago
Having a readonly git copy of the hg repository would be better than the current way where every developper using git creates his own clunky way to track the hg repo. Should it moreover accept pushes, pushing back the patch into hg, it may be even better, but one could also set up another mean to get patches commited into main VCS; git-format-patch and co would be rather handy, then.
Sure, if there's enough people out there in a situation where they can't or won't use hg and need a git mirror we can certainly discuss that. But we'd need more than a handful of people to justify that I would imagine.
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.