Closed Bug 398020 Opened 15 years ago Closed 15 years ago

lay the endcaps to rest

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta2

People

(Reporter: dao, Assigned: dao)

References

(Depends on 1 open bug)

Details

(Keywords: perf)

Attachments

(9 files, 14 obsolete files)

1.42 KB, image/png
Details
1.39 KB, image/png
Details
1.99 KB, image/png
Details
1.82 KB, image/png
Details
592 bytes, image/png
Details
81.44 KB, image/png
Details
71.20 KB, image/png
Details
71.41 KB, patch
mconnor
: review+
Details | Diff | Splinter Review
179.89 KB, image/png
Details
Attached patch WIP (obsolete) — Splinter Review
No description provided.
Attached patch patch (obsolete) — Splinter Review
Attachment #282850 - Attachment is obsolete: true
Attachment #282852 - Flags: review?(mconnor)
Attachment #282852 - Flags: approval1.9?
Blocks: 397946
Attachment #282852 - Flags: review?(mconnor)
Attachment #282852 - Flags: review+
Attachment #282852 - Flags: approval1.9?
Attachment #282852 - Flags: approval1.9+
mozilla/browser/base/content/browser-places.js 	       1.55
mozilla/browser/base/content/browser.js 	       1.855
mozilla/browser/base/content/browser.xul               1.379
mozilla/browser/components/search/content/search.xml   1.102
mozilla/browser/themes/winstripe/browser/browser.css   1.103
mozilla/browser/themes/winstripe/browser/searchbar.css 1.20
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Backed out. This makes the endcaps too tall and causes test failures.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ryan, would it be possible for you to attach a screenshot? I didn't see anything wrong.
I'm downloading an old hourly now and will test with a clean profile.

Could it be that the failure was on Mac?
Attached image what I see with Winstripe (obsolete) —
(In reply to comment #5)
> I'm downloading an old hourly now and will test with a clean profile.

Looks correct with the 20070929_1940 build.
I'm not seeing a difference in text mode either.
No, not Mac - that was where you passed. Windows and Linux, you were failing http://lxr.mozilla.org/seamonkey/source/docshell/test/test_bug344861.html which opens a popup and checks the innerHeight and innerWidth, and since it's a no-toolbars popup that gets the readonly locationbar, I'm not sure whether you made that 2px too big, or whether the toolbar doesn't count against innerHeight, and you made it 2px too small so the content wound up with 2px it didn't expect to get.
Attached patch patch v2 (obsolete) — Splinter Review
This should fix the appearance and the reftest. I've removed the empty space from the icons so that the dimensions can be controlled in the stylesheet. Also, I'm using the "chromeclass-toolbar-additional" class which should be semantically correct and allow the window height to be calculated independently from the endcap, as the appropriate xul.css rules apply earlier than the delayedStartup (browser.js) code that did the hiding.
Attachment #282852 - Attachment is obsolete: true
Attachment #282884 - Attachment is obsolete: true
Attachment #282931 - Flags: review?(mconnor)
Comment on attachment 282931 [details] [diff] [review]
patch v2

umm, wrong patch.
Attachment #282931 - Attachment is obsolete: true
Attachment #282931 - Flags: review?(mconnor)
Attached patch patch v2 (obsolete) — Splinter Review
Attachment #282933 - Flags: review?(mconnor)
Blocks: 399766
Status: REOPENED → ASSIGNED
Summary: more endcap cleanup → lay the endcaps to rest
Attached patch WIP (obsolete) — Splinter Review
needs testing
Attachment #282933 - Attachment is obsolete: true
Attachment #282933 - Flags: review?(mconnor)
Attached patch WIP 2 (obsolete) — Splinter Review
Attachment #285141 - Attachment is obsolete: true
Attached image screenshot with upcoming patch (obsolete) —
Attachment #282934 - Attachment description: Go-arrow.png → mozilla/browser/themes/winstripe/browser/Go-arrow.png mozilla/browser/themes/pinstripe/browser/Go-arrow.png
Attachment #282934 - Attachment description: mozilla/browser/themes/winstripe/browser/Go-arrow.png mozilla/browser/themes/pinstripe/browser/Go-arrow.png → browser/themes/winstripe/browser/Go-arrow.png; browser/themes/pinstripe/browser/Go-arrow.png
Attachment #282935 - Attachment description: Go-arrow-rtl.png → browser/themes/winstripe/browser/Go-arrow-rtl.png
Attachment #282936 - Attachment description: Search-glass.png → browser/themes/winstripe/browser/Search-glass.png
Attachment #282937 - Attachment description: Search-glass-rtl.png → browser/themes/winstripe/browser/Search-glass-rtl.png
Attachment #285220 - Attachment description: Search-addengines.png → browser/themes/winstripe/browser/Search-addengines.png; browser/themes/pinstripe/browser/Search-addengines.png
Attached patch patch (obsolete) — Splinter Review
Tested on XP and Linux (including the reftest that broke with the first patch); hopefully it doesn't explode on Mac. It will, however, most likely look like a visual regression on Mac. There's a new theme coming though, so I don't think we should care.
Attachment #285143 - Attachment is obsolete: true
Attachment #285288 - Flags: review?(mconnor)
Comment on attachment 285218 [details]
screenshot with upcoming patch

I'm up with killing the endcaps, but please make sure that it's still possible to make the search-engine selection stylable as a button with a drop-down; we're going to want that as a button for Windows XP,  a hover state for Windows Vista and a button for OSX. Not sure what the right thing is for Linux, probably no-button.
Attachment #285218 - Flags: ui-review+
(In reply to comment #22)
> I'm up with killing the endcaps, but please make sure that it's still possible
> to make the search-engine selection stylable as a button with a drop-down;
> we're going to want that as a button for Windows XP,  a hover state for Windows
> Vista and a button for OSX. Not sure what the right thing is for Linux,
> probably no-button.

Should be possible. If plain CSS (borders + a few background images) doesn't suffice, a theme can add a binding (hopefully a better one than the current stack).
Attached patch patch v2 (obsolete) — Splinter Review
this aligns the autocomplete popup with the input field
Attachment #285288 - Attachment is obsolete: true
Attachment #285333 - Flags: review?(mconnor)
Attachment #285288 - Flags: review?(mconnor)
Attached patch patch v3 (obsolete) — Splinter Review
this should bring back the rounded border on mac
Attachment #285333 - Attachment is obsolete: true
Attachment #285366 - Flags: review?(mconnor)
Attachment #285333 - Flags: review?(mconnor)
Attached patch patch v3.1 (obsolete) — Splinter Review
updated to trunk, removed the "dropongobutton" locale property
Attachment #285366 - Attachment is obsolete: true
Attachment #285578 - Flags: review?(mconnor)
Attachment #285366 - Flags: review?(mconnor)
Sorry I might sound dumb, but does 'updated to trunk' mean checkin? or something else?
It means that a patch is static while the trunk is constantly changing. As a result, the patch needs to be updated for the changes happening around it on a constant basis. This is also known as bitrot.
I believe this should target M9, because it's relevant for the upcoming Gnomestripe fork and Pinstripe makeover. If we miss either of them, I could of course update the patch, but especially for Pinstripe that could be significantly harder for me to do, as I still don't have access to a Mac.
Flags: blocking-firefox3?
Target Milestone: --- → Firefox 3 M9
Blocks: 395248
Dao: for the site button, here are the ratios Beltzner and I would like to use on each platform, to give the theme a subtle but through sense of visual integration.

Height of intersecting circle to height of square:
OS X, 1 : 1
Vista: 1.2666 : 1
XP: 1.8666 : 1
I should note that these ratios are also going to set the curve on the search button, and the right side of the forward button.
What about Linux?
>What about Linux?

We are going to present our plans for the other platforms to the team of contributers creating our linux theme and see what they think is the best way to go.  Maybe just make the end-caps square, or add slight curves on just the corners?
Blocking, though not blocking beta, though if you get a review in time, feel free to nom for approvalM9
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: Firefox 3 M9 → Firefox 3 M10
Blocks: 402018
Dao, you'll need to update this patch to include the now-forked Gnomestripe.
Attached patch patch v4 (obsolete) — Splinter Review
updated to trunk

mac untested.
Attachment #285578 - Attachment is obsolete: true
Attachment #288018 - Flags: review?(mconnor)
Attachment #285578 - Flags: review?(mconnor)
Attached image screenshot
Attachment #285218 - Attachment is obsolete: true
Attachment #285291 - Attachment is obsolete: true
Attachment #288019 - Attachment is patch: false
Attachment #288019 - Attachment mime type: text/plain → image/png
Priority: -- → P1
Whiteboard: [has patch][needs review mconnor]
That screenshot looks great!
Attachment #282934 - Attachment description: browser/themes/winstripe/browser/Go-arrow.png; browser/themes/pinstripe/browser/Go-arrow.png → browser/themes/winstripe/browser/Go-arrow.png; browser/themes/pinstripe/browser/Go-arrow.png; browser/themes/gnomestripe/browser/Go-arrow.png
Attachment #282935 - Attachment description: browser/themes/winstripe/browser/Go-arrow-rtl.png → browser/themes/winstripe/browser/Go-arrow-rtl.png; browser/themes/gnomestripe/browser/Go-arrow-rtl.png
Attachment #282936 - Attachment description: browser/themes/winstripe/browser/Search-glass.png → browser/themes/winstripe/browser/Search-glass.png; browser/themes/gnomestripe/browser/Search-glass.png
Attachment #282937 - Attachment description: browser/themes/winstripe/browser/Search-glass-rtl.png → browser/themes/winstripe/browser/Search-glass-rtl.png; browser/themes/gnomestripe/browser/Search-glass-rtl.png
Attachment #285220 - Attachment description: browser/themes/winstripe/browser/Search-addengines.png; browser/themes/pinstripe/browser/Search-addengines.png → browser/themes/winstripe/browser/Search-addengines.png; browser/themes/pinstripe/browser/Search-addengines.png; browser/themes/gnomestripe/browser/Search-addengines.png
Attached patch patch v4.1Splinter Review
updated to trunk
Attachment #288018 - Attachment is obsolete: true
Attachment #288852 - Flags: review?(mconnor)
Attachment #288018 - Flags: review?(mconnor)
Blocks: 397331
Attached image screenshot on Linux
Comment on attachment 288852 [details] [diff] [review]
patch v4.1


>+  if (gURLBar.getAttribute("pageproxystate") != aState) {
>+    gURLBar.setAttribute("pageproxystate", aState);
>+#ifdef MOZ_WIDGET_GTK2
>+    // redraw gtk focus ring
>+    if (gURLBar.focused)
>+      gURLBar.focus();
>+#endif

Is there a bug on the core issue here?

this looks ok on Mac, we're doing a bunch of new stuff with Proto so I'm not going to worry about it right at this moment, I'll let Kevin and Stephen know to look at how to style this within that context properly.

Sorry for the delay here.
Attachment #288852 - Flags: review?(mconnor) → review+
Whiteboard: [has patch][needs review mconnor] → [has patch][has reviews]
Keywords: checkin-needed
I think I got all the added/removed files. If you see something I missed, please let me know.

Checking in browser/base/content/browser.js;
/cvsroot/mozilla/browser/base/content/browser.js,v  <--  browser.js
new revision: 1.900; previous revision: 1.899
done
Checking in browser/base/content/browser.xul;
/cvsroot/mozilla/browser/base/content/browser.xul,v  <--  browser.xul
new revision: 1.394; previous revision: 1.393
done
Checking in browser/components/search/content/search.xml;
/cvsroot/mozilla/browser/components/search/content/search.xml,v  <--  search.xml
new revision: 1.107; previous revision: 1.106
done
Checking in browser/components/search/content/searchbarBindings.css;
/cvsroot/mozilla/browser/components/search/content/searchbarBindings.css,v  <--  searchbarBindings.css
new revision: 1.6; previous revision: 1.5
done
Checking in browser/locales/en-US/chrome/browser/browser.dtd;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/browser.dtd,v  <--  browser.dtd
new revision: 1.78; previous revision: 1.77
done
Checking in browser/locales/en-US/chrome/browser/browser.properties;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/browser.properties,v  <--  browser.properties
new revision: 1.52; previous revision: 1.51
done
Checking in browser/themes/gnomestripe/browser/Go-arrow-rtl.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/Go-arrow-rtl.png,v  <--  Go-arrow-rtl.png
new revision: 1.5; previous revision: 1.4
done
Checking in browser/themes/gnomestripe/browser/Go-arrow.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/Go-arrow.png,v  <--  Go-arrow.png
new revision: 1.2; previous revision: 1.1
done
RCS file: /cvsroot/mozilla/browser/themes/gnomestripe/browser/Search-addengines.png,v
done
Checking in browser/themes/gnomestripe/browser/Search-addengines.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/Search-addengines.png,v  <--  Search-addengines.png
initial revision: 1.1
done
Checking in browser/themes/gnomestripe/browser/Search-glass-rtl.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/Search-glass-rtl.png,v  <--  Search-glass-rtl.png
new revision: 1.3; previous revision: 1.2
done
Checking in browser/themes/gnomestripe/browser/Search-glass.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/Search-glass.png,v  <--  Search-glass.png
new revision: 1.3; previous revision: 1.2
done
Removing browser/themes/gnomestripe/browser/Search-provider-bkgnd.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/Search-provider-bkgnd.png,v  <--  Search-provider-bkgnd.png
new revision: delete; previous revision: 1.2
done
Removing browser/themes/gnomestripe/browser/Search-provider-mid-bottom.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/Search-provider-mid-bottom.png,v  <--  Search-provider-mid-bottom.png
new revision: delete; previous revision: 1.2
done
Removing browser/themes/gnomestripe/browser/Search-provider-mid-top.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/Search-provider-mid-top.png,v  <--  Search-provider-mid-top.png
new revision: delete; previous revision: 1.2
done
Checking in browser/themes/gnomestripe/browser/browser.css;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/browser.css,v  <--  browser.css
new revision: 1.137; previous revision: 1.136
done
Removing browser/themes/gnomestripe/browser/endcap-bkgnd-hover.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/endcap-bkgnd-hover.png,v  <--  endcap-bkgnd-hover.png
new revision: delete; previous revision: 1.5
done
Removing browser/themes/gnomestripe/browser/endcap-bkgnd.png;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/endcap-bkgnd.png,v  <--  endcap-bkgnd.png
new revision: delete; previous revision: 1.1
done
Checking in browser/themes/gnomestripe/browser/jar.mn;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/jar.mn,v  <--  jar.mn
new revision: 1.63; previous revision: 1.62
done
Checking in browser/themes/gnomestripe/browser/searchbar.css;
/cvsroot/mozilla/browser/themes/gnomestripe/browser/searchbar.css,v  <--  searchbar.css
new revision: 1.23; previous revision: 1.22
done
RCS file: /cvsroot/mozilla/browser/themes/pinstripe/browser/Go-arrow.png,v
done
Checking in browser/themes/pinstripe/browser/Go-arrow.png;
/cvsroot/mozilla/browser/themes/pinstripe/browser/Go-arrow.png,v  <--  Go-arrow.png
initial revision: 1.1
done
Removing browser/themes/pinstripe/browser/Go-rtl.png;
/cvsroot/mozilla/browser/themes/pinstripe/browser/Go-rtl.png,v  <--  Go-rtl.png
new revision: delete; previous revision: 1.2
done
Removing browser/themes/pinstripe/browser/Go.png;
/cvsroot/mozilla/browser/themes/pinstripe/browser/Go.png,v  <--  Go.png
new revision: delete; previous revision: 1.3
done
RCS file: /cvsroot/mozilla/browser/themes/pinstripe/browser/Search-addengines.png,v
done
Checking in browser/themes/pinstripe/browser/Search-addengines.png;
/cvsroot/mozilla/browser/themes/pinstripe/browser/Search-addengines.png,v  <--  Search-addengines.png
initial revision: 1.1
done
Removing browser/themes/pinstripe/browser/Search-go-rtl.png;
/cvsroot/mozilla/browser/themes/pinstripe/browser/Search-go-rtl.png,v  <--  Search-go-rtl.png
new revision: delete; previous revision: 1.2
done
Removing browser/themes/pinstripe/browser/Search-go.png;
/cvsroot/mozilla/browser/themes/pinstripe/browser/Search-go.png,v  <--  Search-go.png
new revision: delete; previous revision: 1.2
done
Removing browser/themes/pinstripe/browser/Search-provider-bkgnd-rtl.png;
/cvsroot/mozilla/browser/themes/pinstripe/browser/Search-provider-bkgnd-rtl.png,v  <--  Search-provider-bkgnd-rtl.png
new revision: delete; previous revision: 1.2
done
Removing browser/themes/pinstripe/browser/Search-provider-bkgnd.png;
/cvsroot/mozilla/browser/themes/pinstripe/browser/Search-provider-bkgnd.png,v  <--  Search-provider-bkgnd.png
new revision: delete; previous revision: 1.2
done
Checking in browser/themes/pinstripe/browser/browser.css;
/cvsroot/mozilla/browser/themes/pinstripe/browser/browser.css,v  <--  browser.css
new revision: 1.96; previous revision: 1.95
done
Checking in browser/themes/pinstripe/browser/jar.mn;
/cvsroot/mozilla/browser/themes/pinstripe/browser/jar.mn,v  <--  jar.mn
new revision: 1.65; previous revision: 1.64
done
Checking in browser/themes/pinstripe/browser/searchbar.css;
/cvsroot/mozilla/browser/themes/pinstripe/browser/searchbar.css,v  <--  searchbar.css
new revision: 1.18; previous revision: 1.17
done
Checking in browser/themes/winstripe/browser/Go-arrow-rtl.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Go-arrow-rtl.png,v  <--  Go-arrow-rtl.png
new revision: 1.3; previous revision: 1.2
done
Checking in browser/themes/winstripe/browser/Go-arrow.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Go-arrow.png,v  <--  Go-arrow.png
new revision: 1.3; previous revision: 1.2
done
RCS file: /cvsroot/mozilla/browser/themes/winstripe/browser/Search-addengines.png,v
done
Checking in browser/themes/winstripe/browser/Search-addengines.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Search-addengines.png,v  <--  Search-addengines.png
initial revision: 1.1
done
Checking in browser/themes/winstripe/browser/Search-glass-rtl.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Search-glass-rtl.png,v  <--  Search-glass-rtl.png
new revision: 1.3; previous revision: 1.2
done
Checking in browser/themes/winstripe/browser/Search-glass.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Search-glass.png,v  <--  Search-glass.png
new revision: 1.3; previous revision: 1.2
done
Removing browser/themes/winstripe/browser/Search-provider-bkgnd.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Search-provider-bkgnd.png,v  <--  Search-provider-bkgnd.png
new revision: delete; previous revision: 1.2
done
Removing browser/themes/winstripe/browser/Search-provider-mid-bottom.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Search-provider-mid-bottom.png,v  <--  Search-provider-mid-bottom.png
new revision: delete; previous revision: 1.2
done
Removing browser/themes/winstripe/browser/Search-provider-mid-top.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/Search-provider-mid-top.png,v  <--  Search-provider-mid-top.png
new revision: delete; previous revision: 1.2
done
Checking in browser/themes/winstripe/browser/browser.css;
/cvsroot/mozilla/browser/themes/winstripe/browser/browser.css,v  <--  browser.css
new revision: 1.136; previous revision: 1.135
done
Removing browser/themes/winstripe/browser/endcap-bkgnd-hover.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/endcap-bkgnd-hover.png,v  <--  endcap-bkgnd-hover.png
new revision: delete; previous revision: 1.3
done
Removing browser/themes/winstripe/browser/endcap-bkgnd.png;
/cvsroot/mozilla/browser/themes/winstripe/browser/endcap-bkgnd.png,v  <--  endcap-bkgnd.png
new revision: delete; previous revision: 1.3
done
Checking in browser/themes/winstripe/browser/jar.mn;
/cvsroot/mozilla/browser/themes/winstripe/browser/jar.mn,v  <--  jar.mn
new revision: 1.62; previous revision: 1.61
done
Checking in browser/themes/winstripe/browser/searchbar.css;
/cvsroot/mozilla/browser/themes/winstripe/browser/searchbar.css,v  <--  searchbar.css
new revision: 1.23; previous revision: 1.22
done
Status: ASSIGNED → RESOLVED
Closed: 15 years ago15 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [has patch][has reviews]
(In reply to comment #41)
> (From update of attachment 288852 [details] [diff] [review])
> 
> >+  if (gURLBar.getAttribute("pageproxystate") != aState) {
> >+    gURLBar.setAttribute("pageproxystate", aState);
> >+#ifdef MOZ_WIDGET_GTK2
> >+    // redraw gtk focus ring
> >+    if (gURLBar.focused)
> >+      gURLBar.focus();
> >+#endif
> 
> Is there a bug on the core issue here?

Dão, please file a core :: widget: gtk bug on this if there isn't one.
filed bug 405189
Depends on: 405212
This cased the regression in bug 405212 under Linux.
Blocks: 398026
No longer depends on: 405212
Depends on: 405218
I see no Go button in a new profile on Windows. I see it for a short moment, then it is replaced by the star.
Blocks: 405244
This patch works for me with Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9b2pre) Gecko/2007112405 Minefield/3.0b2pre ID:2007112405. But it introduce a usability problem. When the go button appears there is no way to make it disapear. Even when focus is given to an other item the go button persists. Filed bug #405244.
No longer blocks: 405244
Depends on: 405244
Fwiw, I used the "Go" button as a nice way of going back to the anchor position of urls with a hash part.
Also, I liked the "reload" behavior of the "Go" button regarding pages with frames.
The show-and-hide behaviour is really a good feature but maybe there also should be a pref to always show the go-button?
Depends on: 405344
This behavior is not acceptable for regular surfers who associate the go button with the address bar. Additionally a green triangle will only clue some people in that it is a go button. I also should no longer refer to it as a button since it's just an icon with this change. Microsoft screwed up IE's GUI, Mozilla has to start  doing so too? If the wheel is round it works, any enhancements should be optional and off by default. The people who know how to turn it on will and the people who need a go button won't be without one by default. Consistency is a critical point in design.
John, fwiw, I think I agree with you a lot of what you say.
It's probably best to start a discussion about that in the dev apps Firefox mailing list, as bugzilla is not meant for this kind of discussions:
https://lists.mozilla.org/listinfo/dev-apps-firefox
Depends on: 406021
Blocks: 360411
Flags: in-testsuite-
Flags: in-litmus-
Verified fix on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007120704 Minefield/3.0b2pre.   Also verified on windows and linux nightly builds.
Status: RESOLVED → VERIFIED
Depends on: 407805
Depends on: 406360
Depends on: 415958
Depends on: 415000
No longer depends on: 468829
You need to log in before you can comment on or make changes to this bug.