hang/freeze when switch from the new/mail server list from the subscribe dialog

VERIFIED FIXED in M17

Status

SeaMonkey
MailNews: Message Display
P3
major
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Karen Huang, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
Used 05-18-09-M16 commercial build:

hang/freeze when switch from the new/mail server list from the subscribe dialog


1) Select the File| Subscribe dialog
2) Select the news server or mail server from the subscribe dialog will display 
the newsgroups list for subscribe.
3) tried to switch between news server/mail servers (at least there are four 
servers there)
4) Actual Results: hang/freeze when switch from the new/mail server list from 
the subscribe dialog

Expected results: Shouldn't freeze/hang when switch between those servers.
(Reporter)

Updated

18 years ago
Keywords: nsbeta2
QA Contact: lchiang → huang
this might be a duplicate of another problem, which is:

if you use subscribe on a server that you haven't logged into (like imap or a 
news server that requires authentication) it hangs.  it used to bring up a 
password dialog.

that bug is #39761
Status: NEW → ASSIGNED
suresh reported a hang when nothing was selected in the folder pane.

I think I can get it to hang when I migrate, and immediately hit subscribe, with 
out selecting a server.

let me investigate...
Target Milestone: --- → M16

Updated

18 years ago
Severity: normal → major

Comment 3

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
moving to m17, since it is not a m16 blocker.
Target Milestone: M16 → M17

Comment 5

18 years ago
I can't reproduce any problems here. Karen, can you try again with today's
build? thanks!
this has been fixed since I've made the subscribe dialog non-blocking.

marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

18 years ago
Yes. It's fixed.
Verified on 06-30-09-M17 commercial build.
There is no hang/freeze anymore when switch the new/mail server list from the 
subscribe dialog. Verified!!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: huang → search
You need to log in before you can comment on or make changes to this bug.